2

I just installed a new copy of ESXi 5.5 onto a USB (32GB) stick and am trying to set up the configuration. However, when I reboot the server the cahnges I made to configuration like Ip's SSH settings ect. are blanked and revert to the install settings. Any ideas on what is happening and how I can get persistent settings?

Another note is that my server is on a SuperMicro X10SLM+-F MoBo booting from a SanDisk USB 3.0 flash drive, the VM's data store is from a LSI MegaRaid Controller.

the bootbank and altbootbank partitions do not exist from what I can see.

  • Have you tried another USB stick? Can you check the logs on the local console and see if you can find anything suspicious? Also you did remove the installation cd right? – lsmooth Nov 27 '13 at 19:57
  • I don't have many customers going to 5.5 yet because it is so new...A work around for the IP address issue would be to create a DHCP reservation and let it grab that every time. This doesn't doesn't help with the host name or any other settings. – jmoyer8 Nov 27 '13 at 20:02
  • Are you running ESX off the USB or is the installation process running off the USB? – jmoyer8 Nov 27 '13 at 20:02
  • I installed ESXi from a Disk to the flash drive and boot from the flash drive. The disk has been removed. I did receive an error when trying to install a VIB for my LSI controller: Could not stage image profile '(Updated) ESXi-Customizer': (",'the transation is not supported: VIB xxxxxxx cannot be live installed.') – Nat45928 Nov 27 '13 at 20:14
  • More hardware details... – ewwhite Nov 27 '13 at 20:55
3

Your server's booting to the image on the USB drive, but once it's booted to the image it's unable to mount the storage that it booted from; because of this, it's in stateless mode: no VIBs will stick and no configuration will stick because it cannot store them.

Your BIOS knows how to work with your storage, but ESXi does not. I'd guess that ESXi doesn't have drivers for the USB controller that you've got it plugged into.

| improve this answer | |
  • 1
    By the way, using USB boot for this standalone server sounds like a terrible idea. If you have a supported array controller and are running a single-host installation, it makes more sense to use your disks instead of the USB/SDHC boot. – ewwhite Nov 28 '13 at 4:59
  • 1
    This was a winner, I move the stick from a 3.0 port to a 2.0 port and everything worked like a charm. – Nat45928 Nov 28 '13 at 18:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.