On our externally hosted webserver we're running Plesk with centOS-5. I'm trying to get SVN setup on the server, however every tutorial I read tells me to use yum. I can understand this, however my VPS server doesn't seem to have YUM installed.

I've even tried a walkthrough for installing yum, but cant find any rpm for yum which isn't at least 2 years old.

Should I ring up my hosting provider and find out if they can install yum? Is yum usually not installed on plesk systems?

Any suggestions on how to install SVN or yum would be greatly appreciated. Many thanks

  • Why do you believe that you need a more recent version of yum? CentOS 5 is ooold. Nov 28 '13 at 14:31
  • Unfortunately, that was what was installed on the server with plesk. And I actually need yum rather than an updated version of it. Yum is non-existant on the server.
    – Phil Cross
    Nov 28 '13 at 14:32
  • 1
    The problem is not that it has CentOS 5. The problem is that you believe that a 2-year-old package for yum is not adequate. Nov 28 '13 at 14:33
  • I don't have a problem with that. Any version of yum would be better than none. But the links I've tried for the rpm packages are broken. We have a windows network, so I'm more familiar with Windows servers as opposed to Linux.
    – Phil Cross
    Nov 28 '13 at 14:40

yum should be there, also on a Plesk system. If it's missing, I suggest you reinstall it.

wget http://mirror.centos.org/centos-5/5.10/os/x86_64/CentOS/yum-3.2.22-40.el5.centos.noarch.rpm
rpm -ivH yum-3.2.22-40.el5.centos.noarch.rpm
  • Thanks @etagenklo , I'll give it a try in a bit. I contacted our hosting provider who is currently looking into it. I assume if its been removed, it may have been removed for a reason. However if I don't hear anything within the next hour, I'll try installing it. Thanks for the response :)
    – Phil Cross
    Nov 28 '13 at 14:42
  • I once had a customer who removed his yum by accident as he wanted to remove some other packages and put some yum remove commands in one line. What he entered was something like yum remove bla yum remove foo in one line, which effectively caused yum to get removed ;)
    – etagenklo
    Nov 28 '13 at 14:46
  • Couldn't wait around for them to ring back! Just ran the wget and install and seems to have worked! Thanks for the reply :)
    – Phil Cross
    Nov 28 '13 at 14:56

Missing "yum" in CentOS 5 is common for so-called Virtuozzo containers (now called Parallels Cloud Server). I bet your VPS is one of those. "Containers" technology is different from traditional hypervisor VPS, it allows higher density of VPSes on the same machine (thus lower cost), but in exchange applies several limitations.

As a solution you can try the following:

  1. contact your hosting provider and ask for "yum" installed. They probably can do it from their management interface. But they may refuse just as well.
  2. or identify all packages required for SVN, download them to your machine and install through "rpm" tool. Not much convenient if a lot of dependencies involved, but works.

Good luck.


Weird. Is it not located at /usr/bin/yum?

What is the output of:

find / -name yum -type f

(run the above command as root or via sudo for best results)

  • Logged in as root, no results found at all. There's only one mention on yum on the entire server, which is in /var/lib/yum which appears to just be text logs
    – Phil Cross
    Nov 28 '13 at 14:11
  • Plesk uses yum for installing stuff so if it's missing completely there is something wrong. I think it's best to call your provider and ask them to investigate.
    – Marcus
    Nov 28 '13 at 14:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.