0

I have domain with windows 7/xp computers, and windows server 2008 r2 not in domain. This server has shared folder. I want all other computers be able to connect to this server without login prompt. I have googled and tried many provided solutions, but none of them helped me. My settings for now:

  1. Enabled guest account
  2. Granted access in NTFS and share permissions to everyone, guest and anonymous logon
  3. Network access: restrict anonymous access to named pipes and shares - disabled
  4. Network access: let everyone permissions apply to anonymous users – enabled
  5. Network access: shares that can be accessed anonymously – added share name
  6. Network access: sharing and security model for local accounts – guest only
  7. Access this computer from the network – added everyone, guest, anonymous logon
  8. Firewall is turned off

What can be a problem?

0

You never mentioned in your question what the point of failure was, but did you turn off password protected sharing from Advanced sharing settings? It is on by default and must be turned off for anonymous logon to work.

You actually don't need "Guest" and "ANONYMOUS LOGON" on the Share or NTFS permissions if "Let everyone permissions apply to anonymous users" is enabled, but the Guest account DOES need to be turned on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.