2

On puppet-enterprise version 3.3.1, I am attempting to use the puppet node init command on a VMware puppet master node hosted on a VMware VSphere client with VCenter 5.1.0. My puppet master node has its permission configuration on another remote VM with postgresql installed.

I am executing the command in order to install puppet-enterprise on a newly provisioned node. Both are Ubuntu 12.04 VMs. I have manually installed a node previously and set it up as a slave node by accepting the certificate via my puppet console. I am currently attempting to set it up via the command puppet node init instead.

Looking through the docs on the ENC (external node classifier), I have not found mention of the node.yaml file as specified. I have tried to fill the parameters using my answers.install file, my puppet master, and my puppet master console, but it seems my particular configurations do not seem to be working? I do not recall assigning any node group, therefore I used the default specified in the answers.install file as 'pe-puppet', but I have also tried to use the group 'mcollective' as it is a group listed on the console group tab.

I have not done any configuration on my newly provisioned vm which I am trying to install puppet-enterprise on other than log in as root and create a password. Ergo, do I need to set up hosts, hostname, etc. or should I be able to do so via the puppet node init parameters? I imagine that it should be the case in which I should be able to set up a puppet VM without having done any previous modifications on a generic empty Ubuntu VM.

0

Did you follow the procedure there: https://docs.puppetlabs.com/pe/latest/quick_start.html#installing-the-puppet-master ?

You must : - Retrieve the puppet-enterprise tarball on the website, extract its content.

Following your answers, it will generate an answer file.

  • Yes, that is why I asked, but my answer file's parameters were not working. I followed the procedure as specified. – Carl Carlson Nov 6 '14 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.