0

I am having an extremely slow network

netperf -H 11.x.x.21

TCP STREAM TEST from 0.0.0.0 (0.0.0.0) port 0 AF_INET to 11.x.x.21 (11.x.x.19) port 0 AF_INET

Recv   Send    Send  Socket Socket  Message  Elapsed              
Size   Size    Size     Time     Throughput  
bytes  bytes   bytes    secs.    10^6bits/sec  

2288  16384  16384    10.16       0.41   

I dont understand why 11.x.x.21 is showing

ethtool eth0

Settings for eth0:
Supported ports: [ FIBRE ]
Supported link modes:   1000baseT/Full 
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes:  1000baseT/Full 
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Speed: 1000Mb/s

Duplex: Half

Port: FIBRE
PHYAD: 2
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: g
Wake-on: g
Link detected: yes

tried ethtool -r eth0 but no change at all.

so Manually changed by

ethtool -s eth0 speed 1000 duplex full autoneg off

But still no change in netperf ouptput

ethtool -i eth0

driver: bnx2
version: 2.1.11
firmware-version: bc 5.0.6 NCSI 2.0.3
bus-info: 0000:10:00.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes

lspci

00:10.0 PIC: Intel Corporation 7500/5520/5500/X58 Physical and Link Layer Registers Port 0 (rev 13)

Any idea:

why auto negotiation put NIC to half duplex and

Why manually changing to Full duplex couldnt solve anything.

  • 1
    If you manually configure duplex and speed settings, then this should also be configured on the individual switch port. – Dan Dec 3 '13 at 14:25
  • 1
    Have you checked if on the switch side the negotiation is also set to auto and not half duplex? Also might be due to a broken cable. – Chris Dec 3 '13 at 14:26
  • @Chris i forgot to mention that after reboot it came up wit this [ 28.088830] bnx2 0000:10:00.0: eth0: NIC SerDes Link is Up, 1000 Mbps full duplex – Kevin Parker Dec 3 '13 at 14:50
  • So it means your problem is solved or is it still slow? – Chris Dec 3 '13 at 15:30
  • If i restart its detecting proper duplex mode,not able to do i with ethtool – Kevin Parker Dec 3 '13 at 15:58
1

First check that the setting on the device you connect to, do match (1000, autoneg, full-duplex).

Second swap the cable.

Third swap the port you are connecting to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.