3

In an office LAN, with Windows 7 Professional workstations and a FreeNAS Samba server, 2 workstations have intermittent problems in browsing for the other workstations, as well as the FreeNAS server.

However, so far, it appears that typing in the path to any of the workstations which aren't visible via the "browse" function, works. ie. the machine Workstation7 is not visible while browsing via Windows Explorer, but is accessible if I type \\Workstation7 in the path field. Occasionally the workstations exhibiting these symptoms show errors that their connection to the FreeNAS server has failed and only rebooting resolves the issue. All other workstations on the network use identical Windows 7 Professional installations and never have these problems.

I've checked all machines and they're not using Home Groups. All are setup on the same WorkGroup as the FreeNAS server and the network type is set to Work Network.

Temporarily disabling the firewall on the workstations with the issue made no difference, so I know this has nothing to do with the firewall settings.

Any pointers would be appreciated. Thanks.

2
  • If your business/operational process relies on browsing the network to find resources then you're doing it wrong.
    – joeqwerty
    Dec 6 '13 at 16:38
  • The primary issue is the connection dropping, so browsing, or not, the file server becomes inaccessible.
    – zoot
    Dec 8 '13 at 7:41
5

This one is a golden oldie...

The Browse functionality in Network Neighbourhood is something that has NEVER been very reliable and it probably never will be.
Machines "see" each order by virtue of the fact that they will regularly broadcast their presence to the other computers in their Workgroup.
However these broadcasts are often ignored/missed by the other computers (if a machine or the LAN itself is busy broadcast traffic is the first thing to be dropped) so it is very common that some computers show and others don't.
And it get's worse if the systems run different Windows versions due to subtle changes from version to version (even hotfix/servicepack levels can make a difference) or a completely different SMB/CIFS implementation (like Samba).

This has nothing to do with the actual connectivity itself. As you already noticed you can just open \server manually and browse its shares just fine. Or do "Connect network drive" by manually entering the path.

What is worrying are the dropped connections. That shouldn't happen AFTER a connection was established by whatever means.
This indicates that something strange is going on with those particular machines.

A common cause of such issues is power-management. Often Windows 7 will default to disabling the LAN adapter temporarily while "saving power". This doesn't always work well resulting in just the sort of disconnect behavior that you are seeing. So first check if the NIC driver has a Power-management setting and disable it if it is on. (If there is no such setting it is disabled anyway.)
Another possibility is a NIC with a flaky driver. Sometimes the driver is perfectly fine, but the TCP checksum off-loading function (if present) is causing more problems than it's worth. Try updating drivers and/or disabling checksum offloading and see it that makes a difference.

2
  • Thanks for a very thorough response, Tonny. One of the workstations wasn't up-to-date, so that's been done, but there is neither a power-management enable/disable option for the NIC, nor the ability to disable the checksum offloading. The driver is also shown to be up to date.
    – zoot
    Dec 6 '13 at 13:14
  • Windows networking at it's best
    – Jason
    Jun 12 '14 at 2:12
0

I had the same problem on W7pro, but restarting Computer browser service didn't help. I found my fix here by enabling smbv1 and smbv2 Run command prompt as Administrator

sc.exe config lanmanworkstation depend= browser/mrxsmb10/mrxsmb20/nsi 
sc.exe config mrxsmb10 start= auto
sc.exe config mrxsmb20 start= auto

Restart

https://support.microsoft.com/en-us/help/2696547/how-to-enable-and-disable-smbv1,-smbv2,-and-smbv3-in-windows-vista,-windows-server-2008,-windows-7,-windows-server-2008-r2,-windows-8,-and-windows-server-2012

0

You should check for the amount of computers in the same WORKGROUP. I had this problem and I fixed it by changing the WORKGROUP to a different one. I followed a suggestion from a user (in another site) that said Microsoft Windows only accepts up to 10 computers with the same name for WORKGROUPs. As you say, all others machines are using the same Windows installation and don't have the same problem. Maybe you should try changing the WORKGROUP name. I hope this may work for you.

0

make sure this is set to automatic in services

PnP-X IP Bus Enumerator

fixed my problem

-1

i am not sure this is your problem My win 7 tends to loose networked computers from the network neighborhood folder occasionally if clicking on the folder and clicking refresh doesn't work then simply make a short cut named \computername this is a work around it will also put the icon back in network neighborhood this may help someone .It is also better then using an ip address as this is when this problem tends to show up when rebooting a complete network ip address can change and it can take afew minutes to an hour or a day for network neighbor hood to wake up sometimes As I said this is an intermittent problem and relatively rare i have found most home networking is better to use the computer name rather then its ip address

-2

I have two PCs running Windows 7 Ultimate (32bit X86)

I use workgroup sharing and avoid home, office or public. I just want to share my workgroup files, folders and drives and configure my own permissions and security settings from a workgroup and be free of Microsofts way of doing things.

Thus far, I have no problem sharing files, folders or drives between the two, but your problem seems similar to mine.

When I open File Explorer and select "Network" I am missing the icons of the shared computers; hence I cannot double click on them to go to the sub folders that are shared. The explorer view area is blank!

Again, sharing is working, but no icons in "Network". I can type (for example) \OM\OM Office Manager to OA\Desktop and it works. But again... no icons in "Network".

When I right click "Computer" and select "Manage" and go to shares, my shared folders are right there showing all of my setup settings and configurations... but nothing in "Network".

I found a fix for my problem, but I simply want to say that I have probably covered about 200+ websites for the answer. I hate it when I don't know what exactly to type in the search bar and end up on wild goose chases.

Believe me, I have read it all and nothing worked. NOTHING... until I stumbled upon this fantastically simple solution, and I quote:

"Thanks for your reply. I solved it by restarting the 'computer browser service.'"

"COMPUTER BROWSER: Maintains an updated list of computers on the network and supplies this list to computers designated as browsers. If this service is stopped, this list will not be updated or maintained. If this service is disabled, any services that explicitly depend on it will fail to start."

So I Googled it and found this:


"Turning on the Computer Browser service Websense Setup offers the option to turn on the Computer Browser service during installation of the following components on Windows Server 2008. *

Websense User Service *

Websense DC Agent *

Websense Logon Agent If you chose not to have it started, or the installer was not successful, you must turn on the service manually. Perform the following procedure on each machine running an affected component:

1A. Make sure that Windows Network File Sharing is enabled.

1B. Go to Start > Network and click Network and Sharing Center.

1C. Click Advanced Sharing Settings, then select Turn on file and print sharing.

  1. Go to Control Panel > Administrative Tools > Services.

  2. Double-click "Computer Browser" to open the Properties dialog box.

  3. Set the Startup type to Manual.

  4. Click Start.

  5. Change the Startup type to Automatic. This ensures that the service is started automatically every time the machine is restarted.

  6. Click OK to save your changes and close the Services dialog box.

  7. Repeat these steps on each machine running Windows Server 2008 and an affected component."


I did not think this would work, but I had tried everything else.

My firewall is disabled.

My router is up to date.

My Drives and everything else is up to date.

Absolutely nothing that anyone can think of worked except the above configs in "services.msc"

So... good luck to someone else, because this was my fix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.