3

While restarting gitlab I get this:

Starting both the GitLab Unicorn and Sidekiqbundler: command not found: unicorn_rails
Install missing gem executables with `bundle install

I installed gitlab 6.3.0 with ruby 1.9.3 on my centos 6.3 vm.

I tried this from user 'git':

bundle install --without development test pgsql --no-deployment

And I get this:

Enter your password to install the bundled RubyGems to your system:

Which is asking for sudo privileges. It then does for many packages (gems) and fails.

An error occurred while installing i18n (0.6.5), and Bundler cannot continue.
Make sure that `gem install i18n -v '0.6.5'` succeeds before bundling.

Any help will be highly appreciated. Thanks.

EDIT 1:

When I manually try to install any gem (as user 'git') I get this: (here trying with bundler)

gem install bundler ERROR: While executing gem ... (Gem::FilePermissionError) You don't have write permissions for the /usr/local/rvm/gems/ruby-1.9.3-p448 directory.

An ls -l of the directory gives me:

[git@jpvip gitlab]$ ls -la /usr/local/rvm/gems
total 16
drwxrwsr-x  4 root rvm 4096 Nov 21 17:29 .
drwxrwsr-x 24 root rvm 4096 Nov 21 17:21 ..
drwxrwsr-x  2 root rvm 4096 Nov 21 17:29 cache
drwxrwsr-x  8 root rvm 4096 Nov 21 17:29 ruby-1.9.3-p448
lrwxrwxrwx  1 root rvm   57 Nov 21 17:29 ruby-1.9.3-p448@global -> /usr/local/rvm/rubies/ruby-1.9.3-p448/lib/ruby/gems/1.9.1

Also I checked user 'git' was not a member of rvm. So is this the issue? I never changed file/folder ownership or the group file for that matter.

  • What's the complete error message when you try to install the gem via gem install i18n -v '0.6.5' ? – etagenklo Dec 9 '13 at 8:52
  • Updated the question. I can now run gitlab by installing everything as root, but that is rather icky. – mirage Dec 9 '13 at 9:19
1

I experienced similar error bundler: command not found: unicorn_rails after migration from Gitlab 5.4 to 6.0.

The problem was due to cached by bundler value of --without from previous Gitlab version:

root@2e7cc95677d2:/home/git/gitlab# sudo -u git -H bundle config
Settings are listed in order of priority. The top value will be used.
...

without
Set for your local app (/home/git/gitlab/.bundle/config): "development:test:mysql:unicorn:aws"

...

I removed it with

root@2e7cc95677d2:/home/git/gitlab# sudo -u git -H bundle config --delete without`

and performed bundle install again (note that this string is for PostgreSQL configuration):

sudo -u git -H bundle install --without development test mysql --deployment

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.