Could somebody please help me identify an issue I suddenly started having with Replication between 2 of our DCs. I inherited this system which was working perfectly fine but the problem happened suddenly and I am not too sure where to start looking.

This is a school with 2 DCs, both are on Server 2008R2 SP1:

DC1 is also a DNS server

DC2 is also DNS, DHCP and Deployment Server

A couple of days ago I created a policy object and realized that group policies stopped working across the domain. The error message indicated that the gpt.ini file for the policy could not be found.

As soon as I remove the object everything goes back to normal.I tested out the SYSVOL shares on each of the servers by creating files manually and the shares are visible between both of them however if I create a new policy object the physical files for it are not created even locally on the DC that I am working on at the time.

So I ran DCDIAG on both servers and found that DC1 has this error message:

 Starting test: Services       EventSystem Service is stopped on [WES-SVR01]       NtFrs Service is stopped on [WES-SVR01] 

After looking inside Services I am unable to start the File Replication Service or the DFS Service because it gives out an 1068 error saying that 1 of its dependencies cannot be started.

What could be causing this? I ran SFC and it found no errors


2 Answers 2


Have you checked the services the FRS and DFS depend upon. Checking the Properties of both, it looks like they both depend upon RPC, which in turn depends upon DCOM Server Process Launcher, and RPC Endpoint Mapper. Check these to be sure that they are running or runable.

My guess is that you will find an issue with one of these.

  • Thanks Bill, I have looked at the dependencies and both services are Started and are Automatic. DCOM Server Process Launcher and RPC Endpoint Mapper were started and Automatic, Remote Procedure Call (RPC) even though not a dependency is also started and is Automatic. The only process that was not started and was set on manual was the Remote Procedure Call (RPC) Locator, I started this service however it made no difference. The other services above cannot be stopped or restarted as all the options are greyed out, I believe this is intentionally so.
    – Arturski
    Dec 10, 2013 at 9:28

I have resolved the issue. The problem was the COM+ Event System Service.

After carefully looking through services list and troubleshooting the RPC issues I realised that the COM+ Event System which is supposed to be on automatic start has stopped. When I started the service it automatically stopped and after searching around it lead me to this article which solved the issue.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .