• Windows Server 2008 R2
  • Remote Desktop Service role

When I logon locally my command window (cmd.exe) displays with default font that is 8x12. But when I logon remotely and open command window, it opens with the smallest possible font selection. Opening window properties and setting font size, the default 8x12 font is missing from the list.

What should I do to get this font back in the list?

Following screenshots show settings when logged on locally and remotely. Local machine is not Aero capable, but remotely I can have Aero environment. I've also tried setting it to basic, but there was no change.

Local logon
alt text

Remote logon
alt text

  • What version of Remote Desktop Connection is in use? Which display resolutions and DPI settings are in use? Have you tried this from another remote system already? See my answer for why this might be relevant (serverfault.com/questions/56093/…). Sep 15, 2009 at 16:43
  • This started around Vista and happens directly on the console too. Last time I went around in a computer store opening CMD on the displayed computers (mostly laptops) and on about half of them this problem happened. So it is a pretty common problem and apparently no-one knows what causes it or how to solve it... May 25, 2015 at 20:31
  • As explained in this question this happens depending on time, not locale settings. In short: If the current user session isn’t the first session started after a cold boot, the console windows use very tiny 4x6 terminal font May 25, 2015 at 21:16

9 Answers 9


Problem solution found !!! Change "System Locale" = Language for non - Unicode programs to US English and reboot. And then 8 x 12 font available again !

  • 1
    This will break the diacritic marks in most languages.
    – kinokijuf
    Mar 9, 2013 at 14:32

Interesting issue - this answer is just an attempt to encircle it rather than an immediate solution:

Section How Windows NT Matches Fonts within Chapter 8 - Fonts of the MS Windows NT Workstation 4.0 Resource Guide qualifies the Terminal font in question as Raster, fixed, display-dependent size, other than for example the MS Sans Serif font, which is qualified as Raster, proportional, 8, 10, 12, 14, 18, 24 (not to speak of the TrueType fonts, which are all scalable of course).

Unfortunately I have been unable to surface any particular font matching algorithm, still a quote from the almost ancient Windows 95 Printing and Fonts: The Basics might add to the picture, see section Fonts Provided for Compatibility:

The user interface in Windows 95 relies on TrueType fonts. However, three fonts — System, Fixed, and OEM (or Terminal) — are installed to support display and output devices to support other applications that may require these fonts. Each of these fonts supports two display types — 8514/a (1024x768) resolution and VGA (640x480) resolution.

Consequently I suspect the particular font size missing due to non matching characteristics of your remote desktop clients display capabilities, though admittedly this would be quite surprising giving all the other width/height pixel tuples available. Still the fact that the font is missing in PowerShell console too (as per comments to r0cas answer) would back this being a system wide font matching effect rather than an issue of any particular program like cmd.exe.

What should I do to get this font back in the list?

In case Windows font matching would indeed be causing this as suspected above, you might simply be unable to solve this. Eventually changing your clients display resolution and/or DPI settings could make a difference here though; whether this would be an option at all depends on your particular environment and requirements of course.

  • I'd be very interested why this has been voted down: it does not provide an immediate solution but I specifically mention this upfront; it may not be on the right track at all, but then stating what's wrong should be easy, in case I'd happily delete the answer to remove the noise. Sep 16, 2009 at 0:21
  • you've gone deep into this problem. thank you. +1 from me to even it out. Sep 16, 2009 at 10:19

Radek, Your solution don't resolve this problem. If your language is different from the U.S. you don't have diacritics in console aplications after change system locale.

We had the same problem with missing raster fonts 8x12 in Windows 2008 Terminal Server sessions. I resolve this after install converted raster fonts to unicode Trutype fonts from this site: http://www.yohng.com/software/terminalvector.html



Adding property Terminal with value app852.fon to registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts helped me.


Try to set the properties of Screen Buffer 80x420 and Window Size 80x25. This is the default setting of fonts 8x12.

Let me know...

  • no change. 8x12 still missing. Sep 10, 2009 at 14:04
  • Is it the same problem with powershell?
    – r0ca
    Sep 11, 2009 at 13:21
  • yes. the same in powershell window. Sep 14, 2009 at 11:36

This is something of a wild guess, but I wonder if this is related to the remote desktop font smoothing feature. You could try changing the RDC font smoothing setting. Within RDC, select Options -> Experience, then change the Font smoothing setting and try connecting again.

  • no change... even though I hopped for... Sep 11, 2009 at 7:52

Maybe that font is missing on the machine you're logging in remotely from. I think, by default, the windows command line uses font files (*.fon) for each specific size listed in the command prompt properties pane, instead of using normal TrueType fonts (*.ttf). Look in your fonts directory, you should be able to see them. I'm on windows 7 right now, so i can't look at this moment.

  • My question already states that this is only a problem when logging on remotely. Local logon displays thing just fine. Sep 14, 2009 at 11:33
  • i meant the font could be missing on the machine you are logging in from. I said this in the first line of my answer
    – Roy Rico
    Sep 14, 2009 at 17:22
  • Why would my Remote session use any resources (like fonts) from a machine I'm connecting to. Imagine connecting to a non-win machine. This just wouldn't work. No. My machine has 8×12 raster font. Sep 15, 2009 at 13:29
  • 1
    I thought remote desktop was different than VNC, in that, instead of sending an image of your desktop across the wire, it sent drawing commands (example: open window 600x400 pixels, use this font, draw this text). That's why it is able to operate much more efficiently than VNC. This is why I mentioned this. Sorry if that's not the case.
    – Roy Rico
    Sep 15, 2009 at 19:03
  • ok. valid argument. Sep 16, 2009 at 10:20

Something I often see is when RDPing into a machine, the locale of the the machine used to initiate the session is used - and if the remote machine misses that locale, things can mess up quickly... though in this case it seems completely implausible that the 12x8 version of the font is missing some of the characters needed on the initiating machine's locale - but it was my first thought so I thought I'd share it ^^

Have you tried RDPing into it from another machine than the one you're experiencing the problem from? RDP accelerates a lot of stuff at the client.


I did sfc /scannow in elevated CMD prompt (as I read somewhere else). It found no errors, but after I rebooted Windows 7, the 8x12 size came back.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.