2

I've been wrestling with getting a local CPAN installed and configured on a CentOS server with no internet access. What I've done so far is this:

1) Made a full rsync of a CPAN directory onto an external hard drive 2) I then rsync'd it to /root/CPAN/ on my server 3) I ran the initial CPAN init for the config and entered /root/CPAN/ as the source

What I'm limited by:

I'm using a Mac. I tried to install CPAN::Mini on it, but my xcode is corrupted, so most installs won't work for my Mac. Including the make for CPAN::Mini. I don't want advice on how to fix the Mac or installing perlbrew on it, etc. I just want my CPAN dir that I rsync'd to the server to somehow get configured correctly to work like a regular cpan.

Here's the error I'm getting:

root@fire bugzilla]# /usr/bin/perl install-module.pl DateTime
Checking for                 CPAN (v1.81)     ok: found v1.94 
Checking for                 YAML (any)       not found 
Checking for   ExtUtils-MakeMaker (v6.31)     ok: found v6.55_02 
CPAN: Storable loaded ok (v2.20)
  LWP not available
Warning: no success downloading '/root/CPAN/source/authors/01mailrc.txt.gz.tmp160800'. Giving up on it. at /usr/share/perl5/CPAN/Index.pm line 225
Warning: no success downloading '/root/CPAN/source/authors/01mailrc.txt.gz.tmp160800'. Giving up on it. at /usr/share/perl5/CPAN/Index.pm line 225
No external ftp command available

Other things I've tried:

I've tried making the config path to be /root/CPAN/ and /root/CPAN/authors/

I CAN get the cpan shell to show by typing cpan. I have also tried installing the modules from the cpan shell with the same result.

I don't get why cpan keeps trying to reference this weird file called:

01mailrc.txt.gz.tmp160800

What is that?

I found under modules that I can see lots of modules in dirs by_author and by_category, etc. But config examples that I've found in fairly cryptic threads online seem to point to setting the root to be the top level CPAN of the rsync'd CPAN dir I made.

This has been so frustrating. Do I need to run a make command or something on the CPAN dir?

  • Solved it. The config process needed the same root path to the rsync'd CPAN location over and over again. Without adding branches for sources and authors. Like so: /root/CPAN/ – Lynn Dec 13 '13 at 4:02
  • 1
    You can put that comment as an answer and then accept it so that future readers are certain that there's an answer to it. – Wesley Dec 13 '13 at 6:25
  • I did on a similar question. That's really kind of a duplicate actually. serverfault.com/questions/557923/… – Lynn Dec 16 '13 at 22:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.