0

I'm using Ubuntu Server 11.10 x86, and after I make my normal selection (Ubuntu, with Linux 3.0.0-12-generic-pae) from the GRUB menu, the screen just goes blank - there's not even a cursor showing up.

Basically I (suspect that I) had a bad NFS mount tying up the boot process so I fixed that and now it seems like the boot is actually worse off. Here's the problem I had before: Is a bad NFS mount preventing a clean boot?

Not sure if this is useful, but when I hit the 'e' key in the GRUB menu, this is the configuration that shows up:

setparams 'Ubuntu, with Linux 3.0.0-12-generic-pae'

recordfail
set gfxpayload=$linux_gfx_mode
insmod gzio
insmod part_msdos
insmod ext2
set root='(hd0, msdos2)'
search --no-floppy --fs-uuid --set=root <long hex value>
linux /vmlinuz-3.0.0-12-generic-pae root=UUID=<another long hex value> ro
initrd /initrd.img-3.0.0-12-generic-pae

Recovery mode works just fine, networking and all. In fact, if select recovery mode it actually brings up the following menu:

Recover Menu (limited read-only menu)
  resume - Resume normal boot
  fsck - Check all file systems (will exit read-only mode)
  remount - Remount / read/write and mount all other file systems
  root - Drop to root shell prompt

and if I select resume I get the following output:

<timestamp> tpm_tis 00:00: tpm_transmit: tpm_send: error 4294967234
initctl:Event failed

Ubuntu 11.10 <server> tty1
<server> login:

Everything works fine after that.

Other things I've noticed: 1) when booting normally, the Num Lock and Scroll Lock lights on they keyboard show (after pressing the corresponding keys), but the Caps Lock doesn't 2) Ctrl+Alt+Fx to switch TTY's doesn't work 3) this link doesn't help at all: https://wiki.ubuntu.com/X/Troubleshooting/BlankScreen

So, back to the original question: why is my machine not showing anything when booting (in non-recovery mode)?

3

Not sure why this would all of a sudden be a problem but whenever I have this problem adding "nomodeset" to the end of the linux kernel line fixes it. Try editing the grub boot commmands (press e at the boot menu) then edit the kernel line so it looks something like the following then press ctrl-x to boot it.

linux /vmlinuz-3.0.0-12-generic-pae root=UUID=long-hex-value ro nomodeset

If that doesn't work, you know that it's probably something to do with your grub boot options since recovery mode works but normal mode doesn't. I would just compare your recovery boot options to the default and try to figure out which option (or lack of) is causing it to work in recovery mode.

  • appending nomodeset did the trick! – s g Dec 14 '13 at 18:23

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.