0

I'm trying to make squirrelmail work with apache 2.4 + php-fpm (via mod_proxy_fcgi), I want it to work on all virtual hosts when requesting "/wm". On my old VPS, which had apache2.2 and php as its module it was achieved with next:

Alias /wm /usr/share/squirrelmail
<Directory /usr/share/squirrelmail>
RemoveHandler .php  .php3 .php4 .phtml
AddType application/x-httpd-php .php  .php3 .php4 .phtml
php_admin_value open_basedir none
php_admin_value upload_tmp_dir /tmp
php_admin_value session.save_path "/tmp"
php_admin_value include_path .:..
php_admin_value safe_mode off
php_admin_value mbstring.func_overload 0
DirectoryIndex index.php       
</Directory>

I tried ProxyPassMatch ^(/.*.php)$ fcgi://127.0.0.1:1302/usr/share/squirrelmail/$1 but alas apache doesn't allow ProxyPassMatch with directory directive. I kept on experimenting and only "File not found" and "No input file specified" (I assume these are messages from php-fpm since at least 404 error is customized for apache). As of now, I totally don't know what to do to make it work.

0

Well, kinda dirty solution but it worked so I'll just post it here in case someone needs it.
What I did to make it work was:
1. I created symlink in the root folder of virtual host.
2. Added /usr/share/squirrelmail/:/etc/squirrelmail/:/var/lib/squirrelmail/:/etc/hostname:/etc/mailname to open_basedir for pools that were handling these virtual hosts.
Note: Follow symlink option must be on (it's on by default I think)
Hope this helps someone as temporary solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.