I'm trying to deploy an policy for the compatabilty list in IE 8 though at this point I'd settle for just being able to use a .admx

The basic problem I'm running into is when creating/editing a GPO I can't view .admx files but I can view/import .adm files. I get the error message inetres.admx is not a valid template file. Only files that end with the .admx file extension can be added to this Group Poilcy Object.

I am running two 2008 SP1 DCs, with a functional level of 2008. MMC version 3.0, and the group policy editor has features like 'filter' and 'preferences' so it's a quite recent version(though I don't know the exact version). We have a central store setup under C:\Windows\SYSVOL\domain\Policies\PolicyDefinitions\ on our DCs. I have tried creating a new GPO from scratch incase some settings were ported over from the 2003 domain level.

Everything seems like it should be more than ready but for some reason it's failing. I'm hoping it's something pretty basic but it's not obvious to me. Help?

[edits for spelling]


Are you running GPMC/gpedit on the DCs or on a workstation? If it's a workstation, what OS is on it? You can only use .admx files with a GPMC/gpedit version from Vista/2008 and beyond. If it's 2003/XP, it won't work.

  • I've been editing them on 2008 boxes(the DCs). I've also tried editing them on a 2008 SP1 box. If you know how to check what version of gpedit/GPMC is needed I'll be happy to try to run that version(assuming I can find it). – Robert Aug 19 '09 at 19:27

Turns out you can do this nativly in 2008 R2. Unclear what the real issue is but this workaround will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.