The iSCSI mount I have attached to a CentOS server became unresponsive and caused the CentOS server to lock up. When the iSCSI server was repaired the CentOS server was rebooted, but even though iscsi was now okay, the server prompted for the root password to enter maintenance mode and refused to boot.

Once I entered maintenance mode and commented out the lines from /etc/fstab for the iscsi mounts, the server booted. Then I was able to SSH in and mount the iscsi mountpoints just fine.

Why is my iscsi device causing my CentOS server to fail to boot?


I had forgotten to add the mount option _netdev to the iSCSI mountpoint line. Once I changed the line from:

/dev/mapper/vg_iscsi0-mysql     /var/lib/mysql ext4


/dev/mapper/vg_iscsi0-mysql     /var/lib/mysql  _netdev,ext4

The server booted just fine. The _netdev option delays automatic mounting until after the network connections are active. Otherwise the server was trying to mount the iscsi mount with no network connection and that was obviously failing.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.