0

I have 2 2012 servers. I found out there's no share of neither SYSVOL nor NETLOGON on the BDC.

I'm getting many 5002:

The DFS Replication service encountered an error communicating with partner QA-DC for replication group Domain System Volume. 

and 4614:

The DFS replication service initilizaed SYSVOL at local path c:\windows\sysvol\domain and is waiting to perform initial replication

I already tried non-authoritive restore on the BDC and authoritive restore on the PDC according to this guide: http://support.microsoft.com/kb/2218556

I'm afraid that didnt help.

Edit:

I found something strange... Looking at the debug log it looks like dev-dc which is my secondary DC, does not even try to communicate with QA-DC which is the PDC. The logs do show this problematic(?) line:

"Cluster Service is not installed or configured. Skipping VCO Polling".

One more thing I found out is when looking at "DFS Management" snapping I discovered that QA-DC's membership in the "Domain System Volume" is somehow disabled...

0

2 Answers 2

1

After spending hours on top of hours this is the only thing that eventually worked:

http://jorgequestforknowledge.wordpress.com/2010/page/4/

0

The error message indicate a general connectivity issue between your second Domain Controller (stop calling it BDC) and QA-DC, that causes initial replication of SYSVOL to fail. As such, the restore operation doesn't really make sense.

The DFS-R service requires tcp traffic on the following destination ports to be allowed in any firewall between the two:

RPC Endpoint Mapper    tcp/135
Dynamic port range*    tcp/49152-65535 

In addition, you need to make sure that the second DC can resolve QA-DC in DNS.

If these requirements have already been met, inspect the DFSR debug logs. Post any relevant failure details if it doesn't make sense to you. By default, these are located at %windir%\debug\ and will have names like "Dfsr00001.log".


* These are also commonly referred to as Ephemeral Ports or Dynamically Allocated High Ports

3
  • Where do u want the logs from? qa-dc or the pdc? there's no firewall between the 2. Win firewall has also been turned off.
    – JustAGuy
    Commented Dec 18, 2013 at 20:33
  • From the failing DC Commented Dec 19, 2013 at 0:26
  • I'm gonna update on a new post.
    – JustAGuy
    Commented Dec 19, 2013 at 7:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .