1

Recently one of the programs on my server (PWsvr.exe) has stopped working. I opened the program in dependency walker to see if it is missing any required files, and dependency Walker said that GPSVC.dll, IESHIMS.DLL, MF.DLL, MFPLAT.DLL, and MFREADWRITE.DLL are missing.

PWsvr.exe was working perfectly until today, after I installed a fileZilla server, PHP, IIS7, and VC Redistributable pack 2010 and 2012. Since the redistributable packs contain versions of these DLL files I'm thinking they may have caused the problem. I have tried uninstalling these packs and reinstalling VC Redistributable 2005, but that has not solved the problem. I am now at a loss for what is causing this program to malfunction. My company relies on this program for its day to day operations so I would be very grateful for anyone who would be able to help solve this problem.

NOTE: I've also tried using sfc /scannow, however that did not detect any problems

  • This is one reason why we generally dedicate servers to a single purpose. – Michael Hampton Dec 19 '13 at 5:40
  • 1
    @MichaelHampton I'd argue that an FTP server, PHP, IIS and VC Runtimes are all part of a single-purpose web server. – Mark Henderson Dec 19 '13 at 5:41
  • @MarkHenderson Yes, but not the original purpose of this server. – Michael Hampton Dec 19 '13 at 5:42
1

These mostly look like files that were introduced with Windows 7/2008 R2, so they will not be present on Server 2008/Windows Vista machines.

Is this a supported platform by your pwsvr application?

I suspect you're looking at a red herring with those DLLs - with maybe the exception of IESHIMS.DLL - that link to an SO question might be worth looking into.

  • The pwsvr is part of a bigger application that supports Windows Server 2008. I was able to solve the IESHIMS dependency by placing a copy of it in the same folder as the program, but it still does not seem to be functioning. I will try to copy the other DLLs into the folder as well, and look further into possible problems with the IESHIMS DLL. Could all the DLLS be red herring, in which case how would I find what is causing the program to malfunction? – Trent Dec 19 '13 at 5:53
  • UPDATE: Copying the other DLLS got rid of the errors for them, but now EVR.DLL, SYSNTFY.DLL, and WMDRMSDK.DLL are missing – Trent Dec 19 '13 at 5:59
1

First of all, take an image of your server so it doesn't get worse with further changes.

Can you call support for the application? Can they assist you?

If not, install a fresh copy of 2008 on another machine, update it, then install the pwsvr application. Ensure it works, then locate the DLLs you need on that system and move it to the pwsrv program directory on the original system.

  • I can call support, but they do not open til 8AM tom, and I would like to get the problem fixed before then. If I need to I can reinstall the system, however I would rather call support first since that will be a very lengthy process, and we may be down for a few days if I do that. I will go ahead and create a system image in case my changes mess something else up. – Trent Dec 19 '13 at 6:06

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.