I have the following NFS export on my server, with fsid set to a newly generated UUID.


/mnt/data client(ro,fsid=b07f5af6-6b10-11e3-b4c1-00248115724d)

I would then run exportfs -rav which returns no errors, but I don't know how to mount this on the client.

If fsid is set to 0 or root I can mount as follows:

# mount server:/ /mnt/Media

How do I reference the UUID in the mount command or /etc/fstab file?

The following do not work:


Failing with the error: mount.nfs: Operation not permitted

  • It should work as usual, just run mount server:/mnt/data mount_point. The fsid option may be necessary to use when the underlying file-system doesn't have UUID.
    – dsmsk80
    Dec 22, 2013 at 18:54
  • Thanks. You're right, this works, but I was looking for a way to specifically reference the UUID in /etc/fstab, rather than naming the server side path on the client. Maybe this functionality isn't possible, as I can't find it documented anywhere.
    – v25
    Dec 22, 2013 at 20:09

1 Answer 1


What you're wanting to do is not really what the fsid is intended for.

The fsid is meant to help uniquely identify filesystems which may not have their own unique identifiers, such as clustered filesystems. Among other things, this helps eliminate hung systems due to stale NFS mounts by letting you repair and re-export a failed filesystem from a different device, setting the same fsid for the repaired export.

If a filesystem already has a UUID, it would be used by default. Otherwise NFS uses the major and minor numbers of the device node, which isn't very useful when you are exporting a clustered filesystem. So for these you would need to explicitly set an fsid.

The fsid is set on the NFS server, and while it's used on the wire, it is not necessary or even possible to set it on the client side; the client will pick it up on its own.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .