I am building an IDS box with a dedicated sniffer nic which should have no IP.
I can't seem to get the system to come up with no IP on the nic, it either uses DHCP or takes the same IP as the first NIC to come up (eth0 = normal, eth1 = sniffer).

3 Answers 3


in /etc/sysconfig/network-scripts/ifcfg-eth1

  • And test with '/etc/init.d/networking restart' (or maybe just network). Aug 19, 2009 at 19:37
  • Thats what I had, but the server isn't taking it. thanks though Aug 19, 2009 at 19:41
  • Try adding BOOTPROTO=none
    – radius
    Aug 19, 2009 at 20:26

The problem was that NetworkManager was running, which conflicted with the network service, so it inconsistently tried to configure the interfaces (i have no idea where NetworkManager stores its configs)

Solution was to disable the NetworkManger service completely (services + chkconfig off) and then it all started working correctly.

Thanks for your input, i did miss a few things you guys came up with in my initial ifcfg's.


Copy the info from another interface (eth0) into the eth1 file, set it to use a static IP, and make the IP with a netmask of That should do what you want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.