I've installed and configured Exchange 2010 on Server 2012 functionally enough that I can send email between boxes on the local server.

For what it's worth, I'm doing this as a test-run in a virtual environment before I replicate this for production, so I'm currently running the OS on VirtualBox with 1 bridged NIC getting internet access and 1 host-only NIC providing DHCP and such to a W7 VM I'm using to test connectivity. Windows Firewall is currently disabled.

The issue I'm having is sending email to external addresses. In this particular test case I'm trying to use a Gmail address as the target, but I encounter similar problems with Bellsouth as well. They all result in the error message of "451 4.4.0 Primary target IP address responded with: “421 4.2.1 Unable to connect.” Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts."

I set up a CNAME of "mail" that points to "bluebox.amberjohn.co", and in my send connector "mail.amberjohn.co" is the FQDN given in response to HELO. "mx.amberjohn.co" also points to "bluebox.amberjohn.co". SMTP address space is "*" and includes all subdomains.

Now, where I think I may be going wrong is here: I installed SMTP server through the Add Roles and Features wizard. I configured that to deliver mail to SMTP server "localhost" at port 25, using Windows authentication credentials. This doesn't sound right to me but I'm not sure where else to point it, as I'm trying to run an SMTP server in-house.

The idea here is that I can't use my ISP's SMTP server because they rewrite the email headers based on whose credentials are used to authenticate (combats spoofing, I assume). I have 5 users in the organization, and their emails need to maintain their own authorship. So I'm thinking I'll just run my own SMTP server, but something about how I've set this up makes it seem like it's just a big loop.

I tried SMTPDiag but it always fails when looking up MX records for the target, and this appears to be because it's hard-coded to use port 25 when every SMTP server nowadays requires TLS/SSL on 587 or so. It's finding the MX records, it just won't connect. SMTPDiag works fine if I point it to and from a local address, since my server runs on 25.

The only thing I can think of that I haven't tried is opening ports on my hardware firewall, but I'm not yet convinced that it's an issue. Maybe I'm wrong?

I'd appreciate your input.


  • No offense but everything you've done and your level of understanding of SMTP, Exchange Server and email is more kinds of wrong than I can recount in the comment limits. Try this as a first step: enterprisenetworkingplanet.com/datacenter/…
    – joeqwerty
    Dec 23, 2013 at 0:41
  • You say that, but I followed a guide almost identical to the one you posted and with the exceptions of messing around with DNS and installing the IIS SMTP (which in retrospect is prob. unnecessary) followed it to the letter. When I fired up my VM at work just now, my phone lit up from all the test messages I tried sending last night from home, so it was a networking issue all along.
    – Ivan
    Dec 23, 2013 at 14:53

2 Answers 2


Most ISPs block outbound traffic on port 25 for consumers, have you considered that? I didn't quite understand you added SMTP through roles and features? You should use Exchange for SMTP and connect with your client using Outlook or OWA to the Exchange server?

  • It may very well have been some kind of port blocking at the ISP level; I was trying to do this from home when I posted this, but when I came in to the office and fired up my VM all the emails started coming through. So it was definitely some kind of networking issue. Thanks though!
    – Ivan
    Dec 23, 2013 at 14:55
  • Yeah, as a rule of thumb, never test an email server on a consumer/home internet connection without first talking to tier 2 tech support (not the sales guys) for your ISP. It is true that most ISPs block port 25, but some will also block your everything if they see you attempting to send on 25 unexpectedly; makes for an unpleasant night. If your ISP does let you use port 25 on a home connection, feel lucky and hope it isn't shut off soom. :)
    – Ruscal
    Jan 7, 2014 at 18:36

I was trying to do this from home when I posted this, but when I came in to the office and fired up my VM all the emails started coming through. So it was definitely some kind of networking issue. Problem resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.