I'm able to see in phpinfo.php that I've PHP5.4 installed for use. Now, I'm trying to install symfony2 via composer. When I begin installing composer, it gives me an error stating that php5.3 is required but php5.2 is installed. It tells me to upgrade which I did yet I couldn't see any change. I'm checking the PHP version through ssh by php -v and it shows PHP5.2 installed. My simple question is, how can I upgrade this PHP version so that I can install the composer? It's a Debian based Linux OS.

UPDATE: A little more information. I added the following lines to /etc/apt/sources.list to install PHP54.

deb http://packages.dotdeb.org squeeze-php54 all
deb-src http://packages.dotdeb.org squeeze-php54 all

I checked the Debian version by "cat /proc/version" and it is 4.4.5-8.

  • when you done the upgrade did you stop and start apache, etc after the install was done. this could be the problem. – user203756 Dec 28 '13 at 7:53
  • Yes I did that several times. Do you know where is this php installed whose version is shown by "php -v" from the command line? – steady_daddy Dec 28 '13 at 8:04

You most likely have libapache2-mod-php5 5.4 (used by the phpinfo page) installed, but have left php5-cli (php -V uses that) on 5.2.

| improve this answer | |
  • And how would you suggest I upgrade it? – steady_daddy Dec 28 '13 at 8:16
  • Same way as you would update any other package... – Dennis Kaarsemaker Dec 28 '13 at 8:18
  • I did that. It says php-cli is already the newest version. – steady_daddy Dec 28 '13 at 8:20

Since I couldn't get to upgrade the php version, I followed another way to get it done. Taking inspiration from this article here, I managed to installand use composer.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.