I've installed the AWS Command Line Interface using pip by following Amazon's instructions here. I also downloaded my access key id and secret access key into ~/aws/rootkey.csv. However, after the installation, the aws command doesn't work. If I try to simply verify the installation with the command "aws help", I get this error:

ssh: Could not resolve hostname configure: nodename nor servname provided, or not known

I get the same error if I try to run "aws configure".

Since I have my identity (.pem) file in a non-standard location, ~/aws/ec2-t1-micro.pem, I tried specifying it on the command line "aws -i /Users/me/aws/ec2-t1-micro.pem help" but I still get the same error.

Just in case aws can't find my .pem file, I also created a symbolic link:

ln -s ~/aws ~/.aws

This didn't help either.

If I run the command verbosely with "aws -v help" I see:

OpenSSH_5.9p1, OpenSSL 0.9.8y 5 Feb 2013
debug1: Reading configuration data /etc/ssh_config
debug1: /etc/ssh_config line 20: Applying options for *
ssh: Could not resolve hostname help: nodename nor servname provided, or not known

Finally, I downloaded the awscli source from Github and searched for the error message but I couldn't find anything. I also searched the source for the string "ssh" to see if the error was being generated by a call to ssh but I couldn't find anything. This installation is supposed to be easy. I've searched the Internet and I see where this error arises in other situations but nothing particular to running the aws command.

By the way, I did create an inbound security group rule for ssh and have no problems accessing my server using the command: "ssh -i [path_to_my_id_file] ubuntu@[my_public_dns_name]".

Can anyone tell me what I'm doing wrong? Thanks.

  • 1
    I doubt if your 'aws' command is really the awscli or it just run SSH. Could you run which aws; ls -lad $( which aws ) and update the question with that command's output? – Raymond Tau Dec 30 '13 at 19:08

The problem was that a long time ago, I created an alias for ssh called "aws" since I was using my instance so frequently. My bad.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.