I´m trying to set owner and group via rsync and it doesn't seem to be working.

This is the command:

sudo rsync -rlptDvz --owner=cmsseren --group=cmsseren /home/serena/public_html/ -e ssh root@ip:/home/cmsseren/public_html2/

The files sync correctly but doesn´t seem to change the owner and group.

4 Answers 4


It sounds like it is working correctly. Use --owner and --group to preserve (not set) the owner and group names... meaning that you do not want them to change after the transfer.

If you don't use these options, the user and group will be changed to the invoking user on the receiving end. If you want to specify some other user, you will need to add a chown command to your script.

-o, --owner
    This option causes rsync to set the owner of the destination file to be 
    the same as  the source file, but only if the receiving rsync is being run 
    as the super-user (see also the --super and --fake-super options). Without 
    this option, the owner of new and/or transferred files are set to the invoking 
    user on the receiving side...

-g, --group
    This option causes rsync to set the group of the destination file to be the same as 
    the source file. If the receiving program is not running as the super-user (or if
    --no-super was specified), only groups that the invoking user on the receiving side
    is a member of will be preserved. Without this option, the group is set to the default
    group of the invoking user on the receiving side...

man rsync

  • 1
    So how can I chown user and group remotly? Via ssh? Could you please tell me how? I have root acces for both servers. I don´t want to use ssh keys, but tell me all options you know, I´ll appreciate it. Thanks for quick response Dec 31, 2013 at 21:30
  • The command would look something like this: ssh root@ip 'chown -R cmsseren:cmsseren /home/serena/public_html2/*' Dec 31, 2013 at 21:45
  • I tried it, but didn´t work, the owners and users are the same. After making the command it says: stdin: is not a tty Jan 2, 2014 at 17:26
  • It works now, firewall issues. Now I just have to automatize the password input for ssh and rsync Jan 2, 2014 at 18:16
  • I´ll post this in otherquestion, thanks for your help Jan 2, 2014 at 18:51

Version 3.1.0 of rsync introduced the --usermap and --groupmap mentioned by Thomas, but also the convenience option --chown, which works well for your scenario.

    This option forces all files to be owned by USER with group GROUP.
    This  is  a  simpler  interface  than  using  --usermap  and  --groupmap directly,
    but  it  is implemented using those options internally, so you cannot mix them.
    If either the USER or GROUP is empty, no mapping for the omitted user/group will
    occur.  If GROUP is empty, the trailing colon may be omitted, but if USER is
    empty, a leading colon must  be supplied.

    If you specify "--chown=foo:bar, this is exactly the same as specifying
    "--usermap=*:foo --groupmap=*:bar", only easier.

Also, the -o and -g options are required. Excluding them will fail to update their respective attribute, but produce no error.

rsync -og --chown=cmsseren:cmsseren [src] [dest]

This is mentioned indirectly in the manpage, which states that the --chown option "is implemented using --usermap and --groupmap internally", and:

For the --usermap option to have any effect, the -o (--owner) option must be used (or implied), and the receiver will need to be running as a super-user (see also the --fake-super option).

For the --groupmap option to have any effect, the -g (--groups) option must be used (or implied), and the receiver will need to have permissions to set that group.

  • 6
    Why are -og required? It seems illogic to me but it IS required on my system too.
    – Yai0Phah
    Jul 3, 2015 at 8:39
  • 5
    @FrankScience Agreed, it seems illogical. The same question was asked on the rsync mailing list. "I would suggest that the docs for --chown would do well to mention that --owner (--super) and --group are needed". Nov 20, 2015 at 12:58
  • 1
    thanks for the hint that -og may be required!
    – karlsebal
    Dec 18, 2019 at 12:14
  • It does not work for me even with -og
    – Flimm
    Jul 15, 2020 at 17:43

Last version (at least 3.1.1) of rsync allows you to specify the "remote ownership":


Changes tom ownership to www-data (aka PHP/Nginx). If you are using Mac as the client, use brew to upgrade to the last version. And on your server, download archives sources, then "make" it!

  • Docs says: --usermap=STRING custom username mapping, --groupmap=STRING custom groupname mapping Apr 15 at 22:49

Another solution may be to change the remote user that establishes the rsync connection using --rsync-path. I posted a complete explanation here:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.