3

I have installed Varnish in my WordPress Ubuntu EC2 instance as described in this guide:

http://jeffreifman.com/detailed-wordpress-guide-for-aws/install-varnish/

I do have many issues with Varnish and would like to disable Varnish.

I tried to undo the steps described in the guide, e.g. setting ports from :8080 back to :80, then restarting Apache and rebooting Ubuntu. Unfortunately, since my WordPress website does no longer work after these steps, I must have missed something.

When opening my website in a browser, I get the following error message:

Error 503 Service Unavailable

Service Unavailable

Guru Meditation:

XID: 513637370

What is the correct way to disable (and even uninstall Varnish) from my WordPress installation?

4

2 Answers 2

7

if you use CentOS or Red Hat, use this:

service varnish stop

if you want to uninstall varnish, try this:

yum erase varnish

or refer to https://stackoverflow.com/questions/27739853/varnish-cache-server-error-503-service-unavailable

2

Looking at the message, it seems you have forgotten to change back varnish port to it's default 6081, so you should edit your /etc/default/varnish file and change VARNISH_LISTEN_PORT or the -a applicable reference.

If you want to uninstall varnish, it should be as easy as sudo apt-get remove varnish

1
  • 4
    Folks commenting here are assuming a lot of things, in some system setups, if you stop varnish you stop your websites.
    – Mike Q
    Nov 15, 2016 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.