11

I'm getting the error:

Bad Request
Request Line is too large (6060 > 4094)

When I access the a specific url on my server like this:

/api/categorize?packages=package1,package2,...packageN

On nginx.conf I have:

large_client_header_buffers 8 16k;

client_header_buffer_size 8k;

I can't find documentation on that specific issue, the docs for large_client_header_buffers mention 400 Bad request, but changing "large_client_header_buffers" from 4 8k; or 8 8k; or 8 16; didn't fix the problem.

14

This error seems to come from a Gunicorn backend, not from Nginx. You can change it's limit by passing the parameter --limit-request-line or set limit_request_line.

You can see a description here.

  • 3
    This is exactly what I neded. – PepperoniPizza Nov 20 '14 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.