1

I've tried to install nginx on my vps buy following this steps

cd /usr/local/src

wget http://nginxcp.com/latest/nginxadmin.tar 

tar xf nginxadmin.tar

cd publicnginx

./nginxinstaller install 

finally the apache in tweak setting checked working on port 8081 but the server still gives errors and nginex status is down.

this is the error when i restart apache from ssh

Restarting nginx daemon: nginxnginx: [emerg] socket() [::]:80 failed (97: Address family not supported by protocol) already running.

I'm using vps centos 5 whm cpanel

6

i fixed it

my vps is ipv4 not ipv6 so i changed [::]:80 to 80 in ngnix config file and its working fine :)

4

Someone seems to have disabled IPv6 on your server. Re-enable it and try again.

2
  • how to i do this ? what file i have to edit t? – Khodour.F Jan 2 '14 at 6:50
  • 2
    @user3059001 please don't take this the wrong way, but if you're not familiar with how to enable/disable IPv6 on your particular server/operating system you have no business administering the system -- find someone with the requisite experience and skills to assist you. – voretaq7 Jan 9 '14 at 18:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.