When I try to scan a printer with Nessus 4.4.1 I got the following message:

Do not scan printers The remote host appears to be a fragile device and will not be scanned.

How can I enable printers scanning?

2 Answers 2


Polcies -> Preferences -> Do not scan fragile devices -> Scan Network Printers

Bear in mind that this may result in pages of random characters/service fingerprints being printed, and the printer may end up crashing. This is the default setting for a reason.


Go to "Polices" menu

Select your target policy

Then "Edit" button

In "Preferences" choose "Do not scan fragile devices" plugin

Check "Scan Network Printers"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .