1

I've recently added multiple downstream servers to a WSUS environment for a client. All the servers are running WSUS version 3 SP2 (3.2.7600.226). All of them seem to be working well, with one exception.

The location in question is operational, and clients have registered and are receiving updates. However, every synchronization since the initial one has failed. The WSUS management console shows the following error for each failed sync:

SqlException: Timeout expired.  The timeout period elapsed prior to completion of the operation or the server is not responding.
at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)
   at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
   at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
   at System.Data.SqlClient.SqlDataReader.ReadInternal(Boolean setTimeout)
   at Microsoft.UpdateServices.DatabaseAccess.DBConnection.ReadOneRow()
   at Microsoft.UpdateServices.Internal.DataAccess.HideUpdatesForReplicaSync(String xmlUpdateIds)
   at Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.ProcessHiddenUpdates(Guid[] hiddenUpdates)
   at Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.ReplicaSync()
   at Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.ExecuteSyncProtocol(Boolean allowRedirect)

This happens at the end of a sync, after the server has already received the new updates from the upstream server. The changes seem to be getting saved properly, as the new, revised, and expired counts aren't climbing constantly.

I also see Event IDs 10022 and 10032 in the Application log in Event Viewer at the time of each failure.

I've attempted to run the Server Cleanup Wizard on both the upstream & downstream servers, but it's hanging on both when it gets to the stage of deleting unused updates. I ran it on the upstream a week or so ago, just before configuring all the downstream servers, and it worked fine then.

I've also successfully run the reindexing script from this Microsoft forum discussion on both servers. (The cleanup wizard still hangs up after this.)

I've done quite a bit of searching online for this issue, and I've not been able to find anything that works for this situation. I have to think the issue is specific to the downstream server that's failing, since the others are all working fine.

Is there any way to determine exactly what it's doing when it times out?

  • I've found that the cleanup wizard is likely to fail if it gets "too big." Uncheck all but one item and run it in bits and it should finally do the cleanup for you. As for the SQL timeout, I can't tell whether that's related to the cleanup wizard issue or not from the information provided (which is why this is a comment rather than an answer). – Katherine Villyard Jan 3 '14 at 20:27
  • What are you using for SQL, by the way? – Katherine Villyard Jan 4 '14 at 22:33
  • I'm using the Windows Internal Database for SQL. I have management studio installed on both machines so I can get into the database. I don't have Profiler installed, though, which makes this slightly more difficult. – Ben Wyatt Jan 6 '14 at 13:46
  • 1
    Is there anything useful in the SQL-specific error logs? (It's probably in C:\Windows\SYSMSI\SSEE\MSSQL.2005\MSSQL\LOG\ERRORLOG or a similar path.) – Katherine Villyard Jan 6 '14 at 14:26
  • Unfortunately, no. There's nothing interesting in there at all. It's almost like it's having trouble connecting to the database at all. – Ben Wyatt Jan 6 '14 at 14:52
0

It seems that I've found the solution to my issue, although I don't know quite why this wasn't a problem on other machines. Possibly differences between the internal database on different versions/service packs of Windows Server.

In SQL Server Configuration Manager (included with SQL Server Management Studio), the internal database instance (MICROSOFT##SSEE) had Named Pipes and TCP/IP disabled under SQL Server Network Configuration.

After enabling both, synchronization started working properly. I've now run multiple syncs, and they all worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.