0

On a Linux 3.2 kernel: Linux 3.2.0-4-686-pae #1 SMP Debian 3.2.46-1+deb7u1 i686 GNU/Linux on VmWare, i get checksum errors on ipv6 tcp packets.

So I can ping6, but not connect by ipv6 to ssh, smtp, html etc.

I believe, according to http://www.tunnelbroker.net/forums/index.php?topic=2826.0 I have to disable checksum offloading.

I'm supposed to do use this, but it doesn't work.

host:~#  ethtool --offload  eth0  rx off  tx off
Cannot change rx-checksumming
Cannot change tx-checksumming
Could not change any device features
host:~# ethtool -K eth0 gso off
Could not change any device features

Other options?

Hosts with 2.6 kernel does not have this problem; server was ok until upgraded to a 3.2 kernel.

0

I turned off checksum offloading at the virtual switches.

https://communities.vmware.com/thread/167737

In short, ssh'ing to each physixal esx-server, in /etc/vmware/esx.conf setting

/net/vswitch/child[xxxx]/capabilities/ChecksumOffload = "false"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.