I wanted to setup bugzilla on my debian vm.

Everything runs pretty smooth until i do the test suggested by the official manual:

./testserver.pl http://www.localhost/bugzilla

which returns:

TEST-FAILED Fetch of images/padlock.png failed
Your web server could not fetch http://www.localhost/bugzilla/images/padlock.png.
Check your web server configuration and try again.

the things i have done up until this point:

changed the localconfig of bugzilla:

$webservergroup = 'www-data';
$db_driver = 'mysql';
$db_pass = 'myDemoPass';

surfing to http://localhost/bugzilla/ results into a site not found error.

the bugzilla folder is located at /var/www/html/

What could be the reason?

Specs:

Debian 7, Apache2, MySQL, Pearl

Edit: i did a new clean install of debian on a seperate vm and reached a point where i get this error message:

Syntax error on line 73 of apache2.conf
Apache2::SizeLimit at the moment works only with non-threaded MPMs...

the lines i added to apache2.conf:

PerlSwitches -w -T
PerlConfigRequire /var/www/html/bugzilla/mod_perl.pl
  • Aside from the obvious typo? – Michael Hampton Jan 6 '14 at 18:58
  • could you elaborate further? i took those 2 lines for the apache2.conf from the official install manual. – Wandang Jan 7 '14 at 9:31

With regards to the issue of Apache2::SizeLimit at the moment works only with non-threaded MPMs: Bugzilla will only run with Apache's prefork multi-processing module [MPM]. If your Apache build is running another MPM, then Bugzilla will throw this error.

I was having the same issue and was finally able to get the default index.cgi page to load in my browser by changing the multi-processing module that Apache was using. I ran the command a2dismod mpm_event to un-symlink the event module from the /etc/apache2/mods-enabled directory, then ran a2enmod mpm_prefork to symlink the prefork module [which was already in /etc/apache2/mods-available]. Finally, I restarted the server with service apache2 restart so Apache could start using the newly-symlinked module.

list of mpm commands | Bugzilla note on using prefork | Older but relevant information on Apache2's symlinking help.ubuntu.com/10.04/serverguide/httpd.html

Another hint concerning the SizeLimit issue: On Debian, I simply did

apt-get install apache2-mpm-prefork

This automatically uninstalled apache2-mpm-worker. Read also the package description. Bugzilla now works well.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.