1

So, I have two machines:

  • Exchange 2003 - Version 6.0 (Build 7654.0) 4GB RAM, 55GB MDB, Server 2003
  • Exchange 2010 - Version 14.3 (Build 123.0) 8GB RAM, 22GB MDB, Server 2008 R2

There are about 80 mailboxes between both servers.

As per the question title, I am moving all my users from 2003 to 2010. I have moved about 50% of my users, but I keep getting stuck on a few.

Let's start at what is actually happening:

  • Local MoveRequest is initiated and appears to work without an issue
  • Halfway through the move, the Target Mailbox Database dismounts
  • When I attempt to remount the database, it says that there is a log file missing.
  • Even if I ignore the fact that the log file is missing, and accept data loss, I still cannot mount it again until I remove the move request, attempt to mount (and fail), then reset the Information Store service.

Things I have tried:

  • Repairing the database with ESEUTIL after it initially dismounts
  • Accepting 'BadItems' in case of corruption
  • Tried clearing out junk mail from the account manually and trying again
  • Cleaning the target database with EMS
  • Creating a new MDB to use as a target database
  • Removed Storage Quota from source mailbox

As you can see, I'm metaphorically flailing my arms in desperation to get this working.

Any ideas?

I'm going to run ISINTEG on my 2003 server this week, to see if I can find/fix any corruption.

  • Moving mailboxes from a eseutil touched database will always fail to a newer version of exchange. Have you tried moving the mailboxes that give you errors to a new database on 2003 and then moving them to 2010? – AWippler Jan 7 '14 at 1:05
  • 3
    Wait, wait-- you're saying that the Exchange 2010 mailbox database is dismounting when you're moving mailboxes into it? Double-check what you're trying to say. That's some bad mojo if that's the case. I would have expected that you're seeing the Exchange 2003 server dismounting the source database, probably due to some "corruption" in the source database. Seeing the destination database dismount, if that's the case, really casts some doubt on the integrity of your Exchange 2010 server computer. – Evan Anderson Jan 7 '14 at 1:09
  • @EvanAnderson, Yep... That is what is happening... – Vasili Syrakis Jan 7 '14 at 1:27
4
  1. check Exchange 2010 logs why it dismounts. It must have logged something.
    • check the move request log -> EMC -> Recipient Config -> Move request -> right click the move request and check status / or properties there should be a lot of info there.
    • check the system event log -> I think event about dismount should go to Windows log -> application log.
    • check all exchange specific logs -> event viewer -> Applications and service logs -> Microsoft -> Exchange
  2. Your version suggest You got a clean 2010 SP3. Update Rollup 3 For Exchange 2010 SP3 (KB2891587). You are missing an important post SP3 updates to Exchange 2010. http://www.microsoft.com/en-us/download/details.aspx?id=41173
  3. enable circular logging on the target database. That should drastically reduce the amount of logs generated during an move.
  4. check You are not running any shadow copies on the drive where exchange 2010 database / database log are placed.
  5. Exclude from Your antivirus the directory where the database and logs of Exhcange 2010 are placed,
  6. check database size. Although default is 1024GB but just in case check that registry key: http://technet.microsoft.com/en-us/library/bb232092%28v=exchg.141%29.aspx
  7. check if the disk storage for Exchange 2010 is working correctly.
  8. 8GB is not a lot or RAM for Exchange 2010. Check this link http://technet.microsoft.com/en-us/library/dd346700%28v=exchg.141%29.aspx - If I understand correctly You got all the roles on one server. I got similar one under my control and I assigned that server 20GB of ram. 19280MB eaten with regards to store.exe -> 10GB :). Only around 250MB paged. However it was running before with 8GB but it crashed once per 2 weeks (hard lockup).
1

As a response to @BartłomiejZarzecki's answer:

  1. Logs said that the database could not find the logfile, it tried to recover but since I don't have a DAG, it could not. The database dismounted as a result.
  2. Update rollup has been applied. No change in migration, same issue.
  3. Enabled circular logging. This cut down the log size significantly.
  4. There are no shadow copies running.
  5. Antivirus runs at the hypervisor level and is transparent to the server itself, which was probably not helpful in this case since it turns out that the log files were being picked up as a Trojan Script and then deleted. I added an exception and now the migration works fine now.
  6. All db sizes are set to default
  7. Disk storage is okay; this server is a virtual machine.
  8. I will suggest this to my manager, although we probably don't want to do that because we don't make much from this server :)
  • 1
    Happy You solved the problem. Interesting to see the whole picture -> can You post info what kind of antivirus it is and what kind of Hypervisor are You using ? – Bartłomiej Zarzecki Jan 13 '14 at 0:33
  • You better make absolutely certain all exchange data directories are excluded from that antivirus. When you get a virus attached to an email it sounds like it will delete your entire mailbox database...a rather severe overreaction! – Grant Jan 13 '14 at 0:34
  • That's a good idea Grant, I'll be sure to exclude my database folders. The Hypervisor I'm using is VMWare ESXi, with Kaspersky KSV, which is agentless and taps into the guests using VMWare tools. – Vasili Syrakis Jan 13 '14 at 3:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.