I am having problems with my Windows 2008 Enterprise Server box. It is a VM set up as a file Server.

I did some Windows updates on few of my VMs today and they all ran fine, except this one, after a reboot, it is stuck on "Configuring updates: State 3 of 3 - 100% complete." I have read many people with this problem but theirs are stuck on 0%. This one is 100% and also, I can ping the server, access all the shares from the network, even browse to the C$ and do whatever I want. It is just stuck on that "Configuing updates.......100%"

When I browse to the C$ share and go to \Windows\winxsx I see pending.xml there, I can not delete it or take ownership.

I tried booting from the Windows 2008 DVD and go to command prompt, navigate to \Windows\winxsx but pending.xml is NOT there!!

My server shares are working, but I can not use the server


I have seen this state often but never where it persists beyond 1 or 2 reboots which from your answer it sounds like you have already tried.

Have you tried booting into SafeMode? IF you can get into safemode it may allow the update to complete (depending on why its failing).

If that doesn't work I would say you are looking at more drastic solutions. If this is only a fileshare server personally I would probably create a new VM to take over from it and then mount the old servers VHD to the new server so you still have files available.

If you need to persist in trying to get this server booting properly I would take a look at this article: http://pcsupport.about.com/od/findbysymptom/a/windows-update-frozen.htm

Personally however I would carefully weigh up the time it would take to build a replacement server (a known quantity) versus the unknown amount of time you could spend trying to fix this one!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.