Just installed VCenter 5.5 -- simple install method. Defaults all around.

  • Got logged in to web client using Administrator@vsphere.local
  • configured SSO to allow local account as admin.
  • Gave admin perms to this user for the Vcenter server listed
  • Logged back in as this user
  • Attempts to create datacenter just churn endlessly

I've tried creating a datacenter with both the local Administrator account and the Administrator@vsphere.local account --- same results.

Both accounts have carte blanche admin rights to the one listed item, which is the vcenter server itself.

I can't add a host or datastore without defining a top-level datacenter [ from my understanding anyway ]

Am I missing something?

UPDATE: I can't create folders. Also, it seems like the refresh button at top is constantly spinning. Basically, no task will complete.

UPDATE 2: Following ewwhite's suggestion [ see below ], I tried the .net client and met with success. I will try rebooting the server and see if that resolves the issue with the web client. As I understand it, some newer 5.5 VMware Vsphere features are only available in the web client.


My recommendation for vSphere 5.5 these days is to use the vSphere 5.5 appliance (VCSA) rather than the traditional Windows-based vCenter.

I'd suggest the following steps to try to remedy your situation.

  • Reboot your vCenter. I don't know what you did or how it was installed, but perhaps a full reboot will help with any service dependencies. You can probably just restart the Inventory Service, but reboot the whole box.
  • Download the vSphere thick (.Net) client. It behaves more predictably than the vSphere Web Client in some situations. It's a quick way to also get more verbose feedback.
  • If this is a licensed variant of vSphere, you may want to reach out to support.

While vSphere is becoming more complex and bloated, these are basic functions that should and do work for most people. Try the suggestions above to see if they may a difference.

|improve this answer|||||
  • Thanks! Much appreciated. I notice that I'm able to perform these operations with the .net client, as you suggested. I had thought it was a permissions issue -- but it appears to be more an issue with the web client. – Bubnoff Jan 9 '14 at 1:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.