1

I recently replaced the switch that was functioning as the VLAN server for the rest of the network. Since the replacement however, I have not been able to push any new VLANs to the Client switches. Is there any way to force the client VLAN database to be updated? The old VLANs are all working fine -- it is just not receiving new ones.

I've tried

-- On Server Switch, change the domain to something else, then back to original to reset counters
config term
   vtp domain xxx
   exit
config term
   vtp domain abx
   exit
-- on client switches, change the domain to something else, then back.  Also to transparent mode, then back to client
vlan database
   vtp transparent
   exit
vlan database
   vtp client

Despite that, VLAN changes are still not being pushed out.
On my Server switch:

sh vtp status
VTP Version capable             : 1 to 3
VTP version running             : 2
VTP Domain Name                 : abx
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : 001b.d468.1e80
Configuration last modified by XX.XX.64.199 at 1-9-14 07:26:14
Local updater ID is XX.XX.64.199 on interface Vl5 (lowest numbered VLAN interface found)

Feature VLAN:
--------------
VTP Operating Mode                : Server
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 51
Configuration Revision            : 3
MD5 digest                        : 0xB4 0x14 0x13 0x58 0x4A 0xBD 0x2E 0xD3 
                                    0x1E 0x0E 0x76 0x73 0xDA 0xD3 0xBB 0x33 

on the client switch

sh vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 254
Number of existing VLANs        : 49
VTP Operating Mode              : Client
VTP Domain Name                 : abx
VTP Pruning Mode                : Enabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x38 0xFA 0x7A 0x8A 0x21 0x2E 0x98 0x2A 
Configuration last modified by XX.XX.64.199 at 12-26-13 02:35:25

On Server switch

interface FastEthernet1/0/47
 description Crossover to 9.12
 switchport trunk encapsulation dot1q
 switchport mode trunk

sh int fa1/0/47 trunk

Port        Mode             Encapsulation  Status        Native vlan
Fa1/0/47    on               802.1q         trunking      1

Port        Vlans allowed on trunk
Fa1/0/47    1-4094

Port        Vlans allowed and active in management domain
Fa1/0/47    1-2,5-6,8-9,11,17,22,25-27,30-31,34-35,38,43,46-47,49-50,52,55,57,60,62,68,71-72,74,77-78,93-95,105,112,118,202,227-229,233-234,262,520,907

Port        Vlans in spanning tree forwarding state and not pruned
Fa1/0/47    1-2,5-6,8-9,11,17,22,25-27,30-31,34-35,38,43,46-47,49-50,52,55,57,60,62,68,71-72,74,77-78,93-95,105,112,118,202,227-229,233-234,262,520,907

On Client Switch

interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
  • I've tried that (actually added a new VLAN to bump the revision #), but they did not propagate. – John P Jan 9 '14 at 14:16
2

It turns out that the Client switches had a VTP Password set. Unfortunately, there is no way to know what the vpt password is on a client switch ("sh vtp password" only works on the server switch). To fix, I reset the passwords on all switches, then made a VLAN change, which was successfully pushed out. For future reference, here is how it was done:

\\ON Server Switch
# config term
#(config) vtp password newpwd
#(config) exit
\\On Client switch
# vlan database
#    vtp password newpwd
     exit
  exit
1

This discussion helped me out when searching for a similar issue and how I resolved with switches in production..

Symptoms & environment as follows: * Have 2 switches connected. * One switch is VTP Server and the other is client. Both in the same VTP domain * Any new VLANs created on the server switch did not propagate to the client switch. after searching and coming across this discussion I found that the client switch had a VTP password set while the server did not. This "2nd switch", the client was from another office and added to this office with only the one switch. Our VLANs standard across the board at each site and this client switch was a client at the other office it came from. So when added to this office/switch the previous vlans were already there and interfaces could be added but again nothing newly created populated the client switch.

SO.... what I was looking for was an answer as to if we were to just remove the password from the client switch would we hose the vlan database and have to recreate and reconfigure interfaces.... I did a test with 2 switches I had here in the office and set it up exactly as I had in the office but in PRODUCTION and the answer is NO... You're SAFE to remove the password. Once I did so the VLAN that was created before and didn't propagate to the client "did" once the password was removed. I also created new vlans on the server switch to test and it propagated to the client. Hope this helps someone out there that ran into this similar situation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.