2

I have a CentOS 6.4 x32 VPS running NGINX and Drupal 7. To improve response I would like to install and configure APC. To do this my first attempt was to install it using PECL. To start I fired this command

yum install php-pear php-devel httpd-devel

(This is because pear requires phpize which is available in devel which inturn depends on apxs which is available in the httpd-devel package.) I got the following error.

Error: Package: php-devel-5.3.3-27.el6_5.i686 (updates)
Requires: php(x86-32) = 5.3.3-27.el6_5
Installed: php-5.4.23-1.el6.remi.i686 (@remi)
php(x86-32) = 5.4.23-1.el6.remi
Available: php-5.3.3-26.el6.i686 (base)
php(x86-32) = 5.3.3-26.el6
Available: php-5.3.3-27.el6_5.i686 (updates)
php(x86-32) = 5.3.3-27.el6_5
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

I am not sure which direction I should be taking 1) should I downgrade php 5.4 to php 5.3 or 2) should I look for php-devel 5.4 ?

During the course of my research I found a post that mentioned apc can be installed using yum. so i ran this command yum install php-pecl-apc and got a whole bunch of dependency issues Error: Package: php-pecl-apc-3.1.9-2.el6.i686 (base) Requires: php(zend-abi) = 20090626 Installed: php-common-5.4.23-1.el6.remi.i686 (@remi) php(zend-abi) = 20100525-x86-32 Available: php-common-5.3.3-26.el6.i686 (base) php(zend-abi) = 20090626 Available: php-common-5.3.3-27.el6_5.i686 (updates) php(zend-abi) = 20090626 Error: Package: php-pecl-apc-3.1.9-2.el6.i686 (base) Requires: php(api) = 20090626 Installed: php-common-5.4.23-1.el6.remi.i686 (@remi) php(api) = 20100412-x86-32 Available: php-common-5.3.3-26.el6.i686 (base) php(api) = 20090626 Available: php-common-5.3.3-27.el6_5.i686 (updates) php(api) = 20090626 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

This error is similar to the one in the first case and I am unsure which way to go. Any ideas would be appreciated.

2

It seems you've installed php from remi Repo, so you should install php-devel and php-pear from remi as well in order to get the correct package version.

yum install php-devel php-pear --enablerepo=remi 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.