I have an EC2 t1.micro instance running in the Oregon zone, and I wanted to copy that instance and make an m1.medium instance on the Northern Virginia zone. I created an AMI, clicked copy, and selected N. Virginia. I'm trying to modify my security groups but it's not working.

There are 2 immediate issues that I'm having

  1. I cannot add security groups to this instance. The entire networking section is grayed out. I created a new security group, but I cannot add it to the instance.

  2. The status checks have been failing occasionally. When the instance first loaded it worked for about 10 minutes, then it said something about failing to connect to the instance, now it's working again.

I've tried rebooting, and even stopping/starting. When I launched the new instance I made sure to select the same operating system and architecture (Ubuntu 12.04 and x86_64).

  • Have you tried terminating and creating a new EC2 Instance? – Drew Khoury Jan 9 '14 at 22:06

It is not possible to modify the list of security groups associated with an instance (add or remove security groups). You can only specify this list at launch time.

You can modify the permissions associated with existing security groups and they will take effect immediately on all related instances.

Update: Please also note Jason's comment below about changing security groups for instances in a VPC.

  • 2
    You can add/modify/delete security groups if the instance is launched in a VPC, but not if it's a standard EC2 instance. – jaseeey Jan 10 '14 at 7:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.