3

Hey guys so I've been very succesfully OSD'ing various computers the past half year. Using a Task Sequence for Windows 7 Enterprise that I created in SCCM 2012 Machines include: HP 8200, Lenovo T61, T500 T520, even X230..

today I got some Lenovo x240.. so just like I did with the X230, I downloaded the SCCM driver pack from the Lenovo Driver Site for this model.

I took the network drivers from the driverpack added to the boot image, then updated Distribution point and then I fired up a x240 and entered PXE.. now something odd that caught my attention right away was the fact I didn't get to pick Windows PE.. it just started., which means I can't load with 'F8' Options. (Command Support is Enabled)

Anyways it loaded then correctly the boot image and enters Windows PE.

then it says 'Windows is Starting' ... and 'Preparing network' then it reboots...

now So, logically to me that would mean.. network driver issue.. but I'm kinda lost cause I added the 3 drivers that I would think required adding, from the official SCCM package to the boot image:

"Intel® 82567LM-3 Gigabit Network Connection" "Intel® 82579LM Gigabit Network Connection" "Intel® Ethernet Connection I217-LM"

I quickly tested a Lenovo T520, which gets past this point, so nothing is wrong on other devices now since I can't seem to get to the 'F8' Option.. I have no idea how to troubleshoot this.

can anyone help me!? maybe just help me understand why I'm not prompted to select windows PE..

  • Are you using 2012 SP1? – MDMoore313 Jan 10 '14 at 20:50
1

We're having the same issues with 2012 SP1 with the x240. I haven't even started working on it yet though (remote office bought a x240 without telling the sccm team).

My guess is make sure you have the correct OS version of the driver. If you are using WinPE 4.0 then make sure the drivers match up with win 8. WinPE should match up with the corresponding windows version:

PE 4.0 = Win 8. (2012 SP1)

PE 5.0 = Win 8.1. (2012 SP1 CU 2?3? I forget)

Edit***

ok Allando, I got it working over the weekend for us. You need to check your sccm version as it's important.

if you have the console installed check what version the exe is and match it up to the versions on wikipedia: http://en.wikipedia.org/wiki/System_Center_Configuration_Manager

if you have sccm 2012 sp1 or R2 or sp1 CU3 you will need to inject the PE boot image with a windows 8 or 8.1 network driver for the intel card, the driver can be found on lenovo's page here: http://support.lenovo.com/en_CA/downloads/detail.page?DocID=DS037578 if you use 32bit boot images choose 32bit, if you don't choose 64bit I'm going to assume you use 64bit for the rest of this description

Why do you need win 8 drivers when you are deploying windows 7?
The PE environment is completely seperate from what you are deploying, consider it like installing mini windows before you install real windows, once you upgraded to SP1 or newer the boot image OS changed so it's mini win 8 (or 8.1 if you have CU 3 or R2).

Guess what that means? the (correct) driver (in this case windows 7 driver) also needs to be applied to the newly installed OS before it tries to boot into the applied image. I use an apply driver package step after Apply Operating System and before Setup Windows and Configuration Manager. If you use thininstaller then you just need the network and/or storage drivers, I've grown fond of the full driver package like you downloaded, much simpler, little wmi query to check model and you can have all models in one Task sequence.

hopefully that covers it.

  • Update: I booted, using a boot windows XP.. and now that I get in there..I can't even access the harddrive, so I'm thinking now its a storage driver problem.. I will attempt to inject Storage drivers and reply later – Allando Jan 13 '14 at 9:26
  • baah its not the storage drivers. I'm just btw. injecting windwos 7 drivers. I need to deploy win 7, you think I need to inject windows 8 drivers? – Allando Jan 13 '14 at 11:36
  • I'm lost.. simply lost I tried all the drivers I could imagine.. and nothing works – Allando Jan 13 '14 at 13:44
  • ok Allando, I got it working over the weekend for us. You need to check your sccm version as it's important. – hunterm Jan 13 '14 at 15:29
  • i43.tinypic.com/11tvpk7.jpg I did exactly what worked for you. SP1, CU3 .. and I've created brand new boot images.. and they work with T520 T61 X230 with no drivers at all. So I got the win 8.1 drivers like you said.. as you can see on the photo. No cigar :( .. still boots at 'preparing network connections' and I've been through so many sites now making suggestions Getting stuck at this – Allando Jan 14 '14 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.