0

Environment is Exchange 2010 SP3 running on Sever 2008 R2 with the latest rollup 4 installed. Exchange 2003 is gone.

The Problem

When mail-disabling a public folder the public folder object is not deleted below CN=Microsoft Exchange System Objects,DC=Domain (MESO). This means the email address is still in use and cannot be bound to another public folder. When re-mail-enabling the public folder a second object is created below MESO pointing to the same public folder.

Creating a new folder, mail-enabling it changing permissions for the public folder below MESO so that "Domain\Exchange Servers" have full-control and mail-disabling it again works. The public folder below MESO disappears and the email address is available again.

Checked so far

In the permissions tab for MESO "Domain\Exchange Servers" have a deny delete tree. According to this Technet article in the prepare Domain section that is perfectly fine... What I don't get is, why is the Group denied to delete the tree and in the next line is allowed to delete the tree.

What needs to be done, that Exchange 2010 properly mail-disables a public folder i.e. deleting it below MESO?

Update

I opened a call with MS. Will update here, when we have a solution.

  • did You migrate these problematic mail enabled public folders from 2003 ? – Bartłomiej Zarzecki Jan 10 '14 at 17:51
  • yes and no. It started to show on migrated folders. During tests it also showed on a newly created subfolder. I'm gonna test /testfolder as folder and see if that makes any difference. – Jonathan Jan 13 '14 at 12:17
  • Did You execute the procedure of moving public folders ? I mean AddReplicaToPFRecursive.ps1 and MoveAllReplicas.ps1 ? If public folders will be replicated to 2010 and removed completly from 2003 this is the point where I would start testing if it works correctly. – Bartłomiej Zarzecki Jan 13 '14 at 12:27
  • The same for a new folder. Yes we used the procedure for moving public folders. Unfortunately the 2003 server cannot be uninstalled just yet as there are still users on it for at least another month because of some phone dependencies. So the 2003 still is a replica for a sub-tree, but not the one testing in. The foldes we tested on are purely on 2010. – Jonathan Jan 13 '14 at 13:42
  • can You confirm You already removed all the public folders database from 2003 ? It would be more easy to know that only exch2010 handles public folders now. – Bartłomiej Zarzecki Jan 13 '14 at 14:04
0

The called turned out to be a long story...

The solution we came up with was to add MsExchangeTrustedSubsystem on Microsoft Exchange System Objects with permission delete and enabled inheritance

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.