I've got 2 hard disks installed on the server, one of them is specifically for backup purpose. Everything is fine before I upgrade my OS to Windows Server 2012 R2...

And the problem is that after OS upgrade, everytime I perform a full backup, it failed with errors on "C:" and "Bare mental recovery" items. Error messages below:

Backup of volume C: has failed. Backup failed as shadow copy on source volume got deleted. This might caused by high write activity on the volume. Please retry the backup. If the issue persists consider increasing shadow copy storage using 'VSSADMIN Resize ShadowStorage' command.

Meanwhile, during the backup process, there are a bunch of errors recorded on event viewer including:

ID      Source      Message

51      disk        An error was detected on device \Device\Harddisk2\DR4 during a paging operation.
157     disk        Disk 2 has been surprise removed.
153     disk        The IO operation at logical block address 00 for Disk 1 (PDO name: \Device\0000003b) was retried.
14      volsnap     The shadow copies of volume C: were aborted because of an IO failure on volume C:.
140     Microsoft-Windows-Ntfs  The system failed to flush data to the transaction log. Corruption may occur in VolumeId: C:, DeviceName: \Device\HarddiskVolume4.
519     Microsoft-Windows-Backup    The backup operation that started at '‎2014‎-‎01‎-‎11T12:52:56.634161000Z' has failed to back up volume(s) 'C:'. Please review the event details for a solution, and then rerun the backup operation once the issue is resolved.

Each of the error/warning throw more than 10 times during the backup process, and finally a 519 warning ended the whole backup.

I've tried run chkdsk /r on all disks, no error has been reported. I''ve also tried reformat the backup disk to clean all existing data. But the problem is still happening.

One thing worth mention is if I use another USB external portable disk as the backup target disk, the backup process can be performed successfully with no errors. Although warning with ID:157 was captured like 4-5 times during the process.

Update 1: There is also a VSS related error occurred every time when the server is reboot.

Volume Shadow Copy Service error: Unexpected error calling routine RegOpenKeyExW(-2147483646,SYSTEM\CurrentControlSet\Services\VSS\Diag,...). hr = 0x80070005, Access is denied. .

Operation: Initializing Writer

Context: Writer Class Id: {35e81631-13e1-48db-97fc-d5bc721bb18a} Writer Name: NPS VSS Writer Writer Instance ID: {17e952e4-6c26-4c8b-8e56-087055256c7c}

Update 2: I purchased a brand new SEAGATE disk to replace the old WD disk and tried backup the whole system to that disk. Just to verify it's caused by an hardware issue. But unfortunately the errors are still the same.

Update 3: Then I added back the original WD backup disk to my server but connected with a different cable "HDD3". Then surprisingly when I perform backup of my main drive to the old WD disk, all works very well except some warnings through out like 51 (An error was detected on device \Device\Harddisk3\DR7 during a paging operation.) and 157 (Disk 3 has been surprise removed.)

I also tried defragment my drives. All of them can be performed successfully except C:, which has reached 52% of fragments but the process was terminated in the middle with error 257 - The volume (C:) was not optimized because an error was encountered: The parameter is incorrect. (0x80070057)

My current server configuration:

  • Dell PowerEdge T320
  • RAID Controller: PERC H310 Adapter
  • Main Disk: DELL ST1000NM0001 (SAS, 1TB, connected to HDD1 cable, raid-0 layout with only 1 disk attached)
  • Old backup disk: WD WD1001FYYG-01SL3 (SAS, 1TB, connected to HDD2 cable, non-raid disk)
  • New backup disk: SEAGATE ST1000NM0033-9ZM173 (SATA, 1TB, connected to HDD3 cable, non-raid disk)

1 Answer 1


Have you tried replacing the backup disk in the server with a different disk?

This sounds like a hardware or driver problem to me. If you're 100% sure that the errors started happening at the same time as the upgrade, perhaps you should look for updated device drivers from the hardware vendor. Either way, it could be a disk that's trying to die.

If you replace the backup disk and update the drivers and the problems persist, you might want to check to see if your vendor has any diagnostic software for the hard drive controller.

Good luck!

  • 1
    Thank you for the answer. The backup disk I used is pretty common which is WD RE (SAS) 1TB 7200rpm (WD1001FYYG). I really hope I have a spare disk to test this.
    – Xinan
    Jan 13, 2014 at 13:46
  • @Kathierine, I've purchased another disk and tried a backup for C: Un fortunately it failed with the same errors...
    – Xinan
    Jan 17, 2014 at 14:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .