4

I have been trying to get LAMP install upgraded to PHP5.5, Apache 2.4, on Amazon Linux. Per this earlier question, Update PHP with yum on Amazon Linux, I thought I had it beat, but clearly that's not the case.

At the moment I am trying to install the PDO package and I'm getting the following errors:

--> Finished Dependency Resolution
Error: php55-common conflicts with php-common-5.3.28-1.2.amzn1.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I tried the two fixes suggested in the error messages, but that didn't help. Also, tried to erase php-common-5.3.... but could not. Could erase php-common, but that would erase the 5.5 version with it. Any ideas?

Once I am over this hurdle, it's possible I'll strike other hurdles too, so the bigger question is... Has anyone done this before? And perhaps logged the steps in a blog article?

I am using AMI 2013.09.

6

Go ahead and do sudo yum remove php-common, it will be installed again when you do sudo yum install php55. Same goes for any other conflicts.

0

Install the package php55-mysqlnd. I believe this will provide mysql support to PDO.

  • I see a php55-pdo.x86_64 package.... – Scott Oct 24 '17 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.