1

The setup is as follows. Ubuntu-11.10 VM running on an ESXi host. The VM has 3 vCPU assigned.

When running dump (to backup the harddisk) it seems all the processes are assigned to the first vCPU. As we are using compression this loads the vCPU at 100%, slowing down the dump to a crawl.

I have (by using taskset) spread the dump processes to other vCPUs and thereby gained a factor 3 speedup of the backup. Their original affinity was set to 0-2, and if I remove the affinity I have set they all move back to the first vCPU.

I can not fathom what may cause the scheduler to allocate all processes to the same CPU. Can somebody please explain why the task-scheduler may act like this?

4
  • Why are you using 3 vCPUs? – ewwhite Jan 14 '14 at 15:12
  • 4 core hardware, configured with 3 vCPU for this VM. It's an old configuration, I don't know the details of why it was setup like this. – pehrs Jan 14 '14 at 15:47
  • Please show your dump command line. – ewwhite Jan 28 '14 at 13:37
  • @ewwhite: sudo /sbin/dump -0uanj -f - / | ssh -c blowfish user@target.example.com dd of=/Path/to/backup/file – pehrs Jan 28 '14 at 13:43
0

3 vCPUs is not a normal setup. Try this again with 2 or 4 vCPUs. I'm just curious if the behavior would change. You should not need to set any CPU affinity for a process like this.

What does the underlying ESXi host look like? What are its specifications?

Are you literally using the dump command, or is there another backup utility in use? Is that utility single-threaded or multi-threaded?

Edit:

I think this may be related to the compression in use. I'm testing in my environment to see:

sudo /sbin/dump -0uanj -f - / | ssh -c blowfish user@target.example.com dd of=/Path/to/backup/file

4
  • Can't reboot the server, so changing the number of vCPU isn't really an option at the moment. The hardware has an Intel E5540 CPU and about 16 GB of RAM. And it is indeed just the dump command piped over SSH to move the data to a backup server. I run it in parallel for all partitions in the system. – pehrs Jan 14 '14 at 15:53
  • @pehrs Can you try this without compression and see if the behavior is the same? – ewwhite Jan 28 '14 at 13:45
  • Seems to have the same behavior with compression turned off, but it is not as noticeable as the dump becomes network-bandwidth bound. – pehrs Jan 28 '14 at 13:58
  • Did you get any interesting result in your environment in the end? – pehrs Feb 4 '14 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.