0

I have problem while installing weblogic server as windows service , After creating installation script and service created when I'm trying to start the service I got this message :

The service on Local Computer started then stopped. Some services stop atuomatically if the are not in use by other services or programs.

Then after debugging I got this exception:

Exception in thread "main" java.lang.NoClassDefFoundError: Files\Java\j 1/jre/lib/endorsed;C:\Oracle\MIDDLE~1\WLSERV~1/1/endorsed Caused by: java.lang.ClassNotFoundException: Files\Java\jdk1.6.0_31.jre rsed;C:\Oracle\MIDDLE~1\WLSERV~1.1.endorsed at java.net.URLClassLoader$1.run(URLClassLoader.java:202) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at java.lang.ClassLoader.loadClass(ClassLoader.java:306) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301 at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

Error in java application .......

1 Answer 1

2

I have no experience installing Weblogic as a service.

That having been said, seeing the "Files\Java..." string in your error message makes me think that you've got a path being passed as an argument that contains "Program Files" but isn't quoted. Something is parsing that path and breaking it at the space. Double check that you've quoted everything that should be quoted.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .