1

I'm trying to configure Apache's VirtualHost as a reverse proxy for nginx server (all of the current apps are using Apache and this new app is using some specific features of nginx). Used configuration:

<VirtualHost ***.***.***.***:80>
    ServerAdmin ****
    ServerName ****

    ProxyRequests Off
    <Proxy *>
        Order deny,allow
        Allow from all
    </Proxy>

    ProxyPass / http://localhost:8071/
    ProxyPassReverse / http://localhost:8071/
    <Location />
        Order allow,deny
        Allow from all
    </Location>
</VirtualHost>

with nginx/uwsgi running on port 8071 (tried curl it on server and it worked). However, Apache still refuses to route requests to nginx. Is there some specific setting I need to change or some other file to edit?

  • 1
    This seems a bit backwards. Way Apache at all? – Chris Montanaro Jan 17 '14 at 16:57
0

Answer to this was really pretty simple, owners of the domain didn't set it to a new IP address. So if you ever encouter this problem, consider running dig <your-URL> command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.