1

We're having a really strange problem when trying to boot from an mdraid on Debian Wheezy. All references online that I can find tell me that grub 1.99 (which is part of Debian Wheezy) should have no trouble booting from an mdraid volume. We're keep getting a grub rescue prompt, however.

We verified that grub can work with the disks, since booting from a non-raid ext4 formatted partition works without problem. As soon as we put /boot on a RAID array we created with mdadm, grub no longer recognises it.

Although we started out with a RAID5 array with LVM on top, while testing we've moved back to a simply /boot on a 4-disk RAID1 array. These are 4TB disks, so we're using GPT. We installed grub on all disks with the following command:

grub-install --no-floppy --modules="raid mdraid09 mdraid1x" /dev/sda

And for sdb, sdc and sdd, of course.

Grub keeps throwing us to grub rescue. An ls at this time only shows disks and gpt partitions, no md partitions. We've tried recreating the RAID1 with --metadata=0.9, but that didn't change the behaviour at all.

The hardware is a Dell PowerEdge R520 with the PERC 710i RAID controller. We've create RAID0s in the RAID controller for each disk and this seems to work as expected.

No obvious errors are thrown at installation time, either the OS or grub complain.

A reinstall of the grub-pc package doesn't solve the problem either.

We have no further idea what to try and are hoping for some input!

EDIT

We have indeed installed grub to every disk. We are getting a grub prompt, it just cannot read the mdraid. If we add a 'normal' ext4 partition to the machine to boot from, it works.

  • Often, what the bios thinks is sd0 is not what grub thinks is sd0. Worse, sometimes linux doesn't agree, or grub when run from linux may disagree with grub run from bios. It is a PITA. I usually boot a KNOPPIX CD and install grub to every disk in the array. Also - I think /boot must be raid1, never raid5. – Dan Garthwaite Jan 16 '14 at 17:13
  • I've also seen a distro's rescue CD order drives differently than the same installed distro. – Dan Garthwaite Jan 16 '14 at 17:14
  • Yes, already tried that as well :S The server boots fine if we use a normal ext4 /boot partition. It's just that we'd prefer to have that partition on a RAID. – Tim Stoop Jan 17 '14 at 15:22
  • Sorry, a four disc RAID-1? I'm not quite sure how, unless it's RAID-1+0, which isn't RAID-1. Have you tried using a pukka RAID-1, ie two discs? – MadHatter Jan 17 '14 at 16:04
  • Yes, four disk RAID1. Just keep adding them. – Dan Garthwaite Jan 17 '14 at 18:04
0

From my limited knowledge of grub with raid, I have concluded that it is important that the /boot raid array is indeed mounted to /boot when running grub-install, or specified with the boot= option.

How does your /boot/grub/grub.cfg file look like when issuing grub-install? "set" is also interesting to view from the grub rescue console.

  • Heh, we eventually switched to PXE booting, which offered us more options and resilience for the exact problem we were fixing. Thanks for your interest, however! – Tim Stoop Jan 18 '16 at 13:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.