2

I am inside Byobu on ubuntu 12.04 and entered an lxc-console. Unfortunately, the escape sequence for lxc appears to be cntrl-a q. However this clashes with Byobu's which also uses cntrl-a sequence. I tried this questions answer of using cntrl-a a q, but it appears that cntrl-a a tries to go to the next window in byobu! I also tried changing the escape sequence by using f9, but it appears that this is broken as it does not change from cntrl-a. What is the solution other than killing the container from outside that screen?

1

You could open up a second connection to an other tty.

Then you could use Ctrl+a,k to kill the screen window you are trapped in.


To prevent this from happening for consecutive sessions you can define the escape character to e.g. Ctrl+e:

# lxc-console -e '^e' -n containername
0

Using this answer, you can:

Send ctrl+a (enters the BYOBU command area), then, a to drop into the lxc-console command area, then q to quit the lxc console.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.