0

Using Amazon EC2 I successfully launched a Windows Server 2012 instance. I was able to connect to it using a remote desktop client and configure it as needed.

From the EC2 console I then selected the option to "Launch More Like This" and a new instance was successfully launched.

However, when I try to connect to it using the same credentials as the other instance, it fails.

Instead of showing me the Windows desktop I get a login screen for 'Other user' and a message telling me the username or password is incorrect. If I click OK, I can then enter the username 'Administrator' and the password but that fails in the same way and takes me back to the initial screen.

How do I connect to instances launched in the way described?

  • Did you try right-clicking the instance in the console and clicking "Connect"? It'll generate a .rdp file for that specific instance. – Nathan C Jan 17 '14 at 12:43
  • Yes, that's exactly what I did. – ksl Jan 17 '14 at 13:54
1

"Launch more like this" is more of a config copy (vpc id, subnet etc...) than a copy of the machine itself. The Administrator password was changed to something new during the instance launch. You can right-click your instance and click "Get windows password".

The only way to keep the same Administrator password is to create an AMI from your original instance and launch instances based on that AMI.

  • When I right-click the instance to get the Windows password it presents a screen where the Key Name is the same as that for the original instance. The password (when I decrypt it) is also therefore the same. – ksl Jan 17 '14 at 13:58
  • When you say 'create an AMI from your original instance' do you mean the 'Create Image' option? – ksl Jan 17 '14 at 13:59
  • Yes. It will create an AMI then you can choose that AMI when you launch an instance. – typositoire Jan 17 '14 at 14:09
  • I followed you advice and created an AMI from my original instance. Now, when I launch instances based on that AMI the password is the same. Thanks for the advice. – ksl Jan 23 '14 at 7:35
  • No problem!! Always happy to help! – typositoire Jan 23 '14 at 14:03

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.