1

Whenever an upload takes longer than 22 seconds, then the upload ends up with connection was reset error. On the server side, the connection is in FIN_WAIT2 state. The problem is, that apache2 Timeout is 300 seconds, max_input_time is 60 seconds.

I have no idea what else can be causing this.

  • Are you using a php file to upload files ? – krisFR Jan 20 '14 at 19:10
  • Yes .. I tried several scripts .. and even php file manager (phpfm.sourceforge.net) failed. – aa007 Jan 20 '14 at 19:32
1

To upload files using php you have to consider these settings in your php.ini file :

As a sample, my production server for file upload is setup like this :

upload_max_filesize = 2000M
post_max_size = 2000M
max_input_time = 60
memory_limit = 3092M
  • All of that is OK - when I change to https then everything is working correctly. So I guess it's a problem on my ISP's side, I hope they will be able to fix it. – aa007 Jan 24 '14 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.