0

I seem to have a problem with my SSL Configuration and was wondering if anyone could help me. I've set everything up correctly (as far as I'm aware)

But for some reason when I hit 'https://corymosey.co.uk' - I get an error saying: The identity of this website has not been verified. • Server's certificate does not match the URL. • Server's certificate is not trusted.

Also, it seems to be using 'dev.corymosey.co.uk' When you click for more details which is my hostname?

I'm also using CentOS 5.

Can anyone help me?

Kind Regards, Cory.

  • We're really going to need more info to even begin to help. For starters, what kind of web server are you running? Doing some research on your own, and posting the solutions you have tried, will get more attention. Be specific! – tdk2fe Jan 21 '14 at 8:25
  • I'm running CentOS 5 with Apache and OpenSSL, I've followed tutorials on what commands to run to get the key etc, I've just tried a self-signed one which seemed to work, the SSL is by PositiveSSL and is signed to corymosey.co.uk, I've set it up and been sent the files. – Cory Mosey Jan 21 '14 at 8:34
1

Actually seems to be OK now, at least I don't get any warnings in IE 10.

Maybe your browser doesn't have the intermediate CA certificate pre-installed and you need to add the SSLCertificateChainFile configuration option to Apache.

In the SSLCertificateChainFile you should concatenate all the intermediate and the root CA certificates used to sign your public SSL certificate. Many providers supply them already when they send you your signed SSL certificate.

  • Cheers HBruijn, I had to change the files from the SSL config within Apache to the correct files which I didn't realise. – Cory Mosey Jan 21 '14 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.