2

I want to install the software TinyOWS on a RHEL 6 server. I followed the instructions:

$ wget http://download.osgeo.org/mapserver/tinyows-1.1.0.tar.bz2
$ tar xvjf tinyows-1.1.0.tar.bz2
$ cd tinyows-1.1.0
$ ./configure
$ make
$ sudo make install

But I couldn't complete the installation because the TinyOWS has a dependency on a library libxml2 version 2.8 or higher. The version of libxml2 on my RHEL6 server is 2.7. The reason why libxml2.8 is a bug in the older versions of libxml2 that is described here: http://mapserver.org/tinyows/libxmlschemagmlbug.html

So, it seems that I have to install the libxml2 library version 2.8 or higher on a RHEL 6 server. I tried to run:

 yum update libxml2

but the highest version of libxml2 on the RHEL repository is 2.7.6.

I tried to workaround the problem by downloading the libxml2-2.8.0-1.x86_64 rpm file from ftp://xmlsoft.org/libxml2/, but when I tried to install the downloaded .rpm I got a lot of unmet dependency warnings:

--> Finished Dependency Resolution
Error: Package: libxml2-2.8.0-1.x86_64 (/libxml2-2.8.0-1.x86_64)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libxml2-2.8.0-1.x86_64 (/libxml2-2.8.0-1.x86_64)
           Requires: libz.so.1(ZLIB_1.2.3.3)(64bit)
Error: Package: libxml2-2.8.0-1.x86_64 (/libxml2-2.8.0-1.x86_64)
           Requires: liblzma.so.5()(64bit)
Error: Package: libxml2-2.8.0-1.x86_64 (/libxml2-2.8.0-1.x86_64)
           Requires: libc.so.6(GLIBC_2.15)(64bit)

You could try using --skip-broken to work around the problem

I'm quite afraid of messing up the system by installing all these dependencies. For example, I read that the glibc 2.14 library is unavailable for RHEL 6.

What would you recommend to to to install libxml2.8 on RHEL 6? Or is there any other way how I could 'apply a patch' to my current installation of libxml2.7?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.