1

I have an app on Heroku, for which I have pointed a Cname record to both the www and naked domain.

However this is creating a problem when people try to reply to our emails from that domain. They are being routed through Heroku somehow - it is only on reply though:

Delivery has failed to these recipients or groups:

paul@us-east-1-a.route.herokuapp.com
The server has tried to deliver this message, without success, and has stopped trying.         

The following organization rejected your message: us-east-1-a.route.herokuapp.com.

Diagnostic information for administrators:

Generating server: sofia.vsl-net.com

paul@us-east-1-a.route.herokuapp.com
us-east-1-a.route.herokuapp.com #<us-east-1-a.route.herokuapp.com #4.4.7> #SMTP#

In the case above, they were replying to an email sent from paul@mydomain.com.

Fasthosts as usual are no help at all, can anyone shed some light on this?

Thanks

ETA - It only seems to be some people that are having problems replying to us. I can send/receive from another imap account, and also a gmail account.

0

CNAME records cannot coexist with MX records. Your MX records will be ignored and the domain will get the MX records of the CNAME's destination (likely something like proxy.heroku.com here).

  • Thanks for answering. So how can you use email on the same domain that you have a Heroku app? Surely you've got to have a CNAME record in their somewhere as Heroku will not let you have an IP address to add A records? – Ralph King Jan 22 '14 at 10:36
  • Scratch the above - I think i've fixed it. I removed the CNAME record for the naked domain, which as you say can't work, and instead added an A record, and used the wwwizer.com/naked-domain-redirect service to do a 301 redirect. Just waiting for things to propagate to see if it's actually worked... – Ralph King Jan 22 '14 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.