I've tried several existing and new instances of various Ubuntu server instances (12.04 LTS - 13.10). The host is an old desktop I've converted to a host, and is a C2D E6550 with 8GB DDR2.

Basically, if the Ubuntu guests are in an "off" state, and I boot them, they boot normally. The issue is, every time I do a reboot (not a reset), they never come back up. The guest CPU will peg at 100% and never come up. If I turn it off and restart the guest, it comes back up. It's ONLY on reboot. It will get past the GRUB loader and then it sits on a black screen forever, with the CPU pegged.

I have an AMD VM host, 4GB DDR2, and it has no issues rebooting the same instances. I also have a newer Core i7 desktop and it too has no issues rebooting. It's just this E6550 machine.

Windows instances have no issue at all. Just Ubuntu (I've tried Centos but never could get it to boot).

The same machine previously was a Windows 2012 (not R2) server with a Hyper-V role, running the same guests, and don't recall it having this same issue.

Does something in the BIOS need to be adjusted? I have no CPU compatibility modes enabled, and all setups are defaults. Disks are IDE. All OSes are 32-bit.

EDIT: I tried x64 13.10 instance and it works normally. It seems to be only 32-bit. I was using 32-bit mainly due to the small amount of RAM required/needed for these instances.


  • I have the same experience on hyperv 2008r2. With dual AMD 16 core processors (don't have the model handy). I experience the problem with 64 bit guests of ubuntu 12.04. – Grant Jan 25 '14 at 14:43
  • Do you have kexec enabled on the guest? Check /etc/default/kexec. You could see if the same behaviour persists if you run coldreboot instead of reboot to reboot the guest. – James Hebden Jan 26 '14 at 23:40

Some more information on the AMD processor model may help. This could be related to compatibility with features on the processor. Being that Server 2012 R2 is x64 and x64 virtual machines are working fine I would suspect either a feature on the CPU is enabled/disabled in the BIOS causing the issue or a setting with CPU compatibility within Hyper-v needs to be enabled. Without more information it's hard to say.

Also, was the Server 2012 (not R2) install x86 or x64?

  • As far as I know, there's no such thing as a x86 version of Windows Server 2012. – Trondh Jan 26 '14 at 15:58
  • The AMD is a 4850e. The original OS on there (before I converted to Hyper-V 2012 R2) was 2012 (non R2) x64. – Ryan Peters Jan 27 '14 at 12:24
  • Check your BIOS settings and see if the AMD NX bit is enabled. It is a requirement for Hyper-V to run properly in addition to virtualization being enabled. Here's a link for reference with the requirements for settings and cpus: technet.microsoft.com/en-us/library/cc731898.aspx other than that, I'm not certain why R2 would have broken this. Was the change to R2 an in-place upgrade or a fresh install? – Mike Naylor Jan 27 '14 at 15:36
  • Were you able to resolve the issue? – Mike Naylor Jan 31 '14 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.